summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 23:03:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-29 00:17:54 -0400
commit3e39e020cf77a03bf4672fc281dec55f1df53042 (patch)
treee36898a7b581700e21598f6629dcbefe03b791ab /x11-misc/x2vnc
parentx11-misc/x2vnc: EAPI7->8, use https, add some missing deps (diff)
downloadgentoo-3e39e020cf77a03bf4672fc281dec55f1df53042.tar.gz
gentoo-3e39e020cf77a03bf4672fc281dec55f1df53042.tar.bz2
gentoo-3e39e020cf77a03bf4672fc281dec55f1df53042.zip
x11-misc/x2vnc: fix build with clang16
Skipping revbump (for potential runtime fixes with other compilers) given was done in previous commit. Closes: https://bugs.gentoo.org/870652 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/x2vnc')
-rw-r--r--x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch33
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch b/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch
new file mode 100644
index 000000000000..7b9cd1b50b69
--- /dev/null
+++ b/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/870652
+--- a/rfbproto.c
++++ b/rfbproto.c
+@@ -25,2 +25,4 @@
+
++#include <ctype.h>
++#include <time.h>
+ #include <unistd.h>
+--- a/sockets.c
++++ b/sockets.c
+@@ -33,2 +33,3 @@
+ void PrintInHex(char *buf, int len);
++int tunnel(char *gatewayhost, char *remotehost, int remoteport);
+
+--- a/vncauth.c
++++ b/vncauth.c
+@@ -28,2 +28,4 @@
+ #include <sys/stat.h>
++#include <time.h>
++#include <unistd.h>
+ #include <vncauth.h>
+--- a/x.c
++++ b/x.c
+@@ -26,2 +26,3 @@
+ #include <sys/types.h>
++#include <time.h>
+ #include <unistd.h>
+--- a/x2vnc.c
++++ b/x2vnc.c
+@@ -25,2 +25,3 @@
+
++#include <time.h>
+ #include <unistd.h>
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
index f148da4c7b74..03384930c47f 100644
--- a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
@@ -28,6 +28,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/expectk.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_install() {