summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-31 08:07:42 +1000
committerSam James <sam@gentoo.org>2022-07-31 02:29:38 +0100
commit32cfc09a0bb09a6780867efc7461bbc706d6b307 (patch)
treeaaf2ace637b96bdf953ea6e17fd07cb8d3c9e9f3 /x11-misc
parentsys-libs/glibc: Stabilize 2.35-r8 amd64, #856481 (diff)
downloadgentoo-32cfc09a0bb09a6780867efc7461bbc706d6b307.tar.gz
gentoo-32cfc09a0bb09a6780867efc7461bbc706d6b307.tar.bz2
gentoo-32cfc09a0bb09a6780867efc7461bbc706d6b307.zip
x11-misc/xmobar: add 0.44.1
Closes: https://bugs.gentoo.org/847283 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xmobar/Manifest1
-rw-r--r--x11-misc/xmobar/metadata.xml31
-rw-r--r--x11-misc/xmobar/xmobar-0.44.1.ebuild97
3 files changed, 109 insertions, 20 deletions
diff --git a/x11-misc/xmobar/Manifest b/x11-misc/xmobar/Manifest
index 3a0dfd778cd5..840013c22735 100644
--- a/x11-misc/xmobar/Manifest
+++ b/x11-misc/xmobar/Manifest
@@ -1 +1,2 @@
DIST xmobar-0.37.tar.gz 139585 BLAKE2B b7f115dc18f1ec6f2dc767c0cf6f4f94a9e3691cd5823302cc033542a10430bd3f29f906c4b1d8705cfae7e999695ac85d03d0c3ecfe4f7efaeac627a5e61d3f SHA512 a2904f3658ea32654ba343cd2c815928900e29e819dbc5ddff931601f42bae244365d2636ffce8b52c4dc57f88f3abebeffc62924fd3b39e197698d7b0da7d5d
+DIST xmobar-0.44.1.tar.gz 156756 BLAKE2B bee81627744146989b402ae04d36edb5e4a69686b546457afebad81cda96ece4ce0ace8a2855bd5136610be3fc396c2f62121ea062fffb1ad837145cf3238fdb SHA512 e04f3f9f40ffa4095df2b523916686d93d28b4cbb880f7732cf63d6f1915e721043764b9d723ed8b3c4938c3df749d0e5a9ddb9a9e64a2a015f8f0d6b3f46c97
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 86ecf67faf16..85386171573c 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -6,25 +6,16 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="alsa">Use alsa-mixer to get the volume from soundcards</flag>
- <flag name="dbus">Publish a service on the session bus for controlling xmobar</flag>
- <flag name="inotify">inotify support (modern Linux only). Required for the Mail and MBox plugins</flag>
- <flag name="mpd">Support mpd plugin</flag>
- <flag name="timezone">Enables localized date support</flag>
- <flag name="mpris">Enables MPRIS v1, v2 support</flag>
- <flag name="rtsopts">Reduce process wakekups frequency to decrease CPU usage</flag>
- <flag name="uvmeter">Plugin to show UV data for Australia</flag>
- <flag name="weather">Enable weather plugin</flag>
- <flag name="wifi">Wireless info support via nl80211. Required for the Wireless plugin on systems running Linux</flag>
- <flag name="iwlib">Wireless info support via Wext ioctls (deprecated)</flag>
- <flag name="xft">Use Xft to render text. UTF-8 support included</flag>
- <flag name="xpm">Enable usage of xpm for icons</flag>
+ <flag name="alsa">Use alsa-mixer to get the volume from soundcards.</flag>
+ <flag name="dbus">Publish a service on the session bus for controlling xmobar.</flag>
+ <flag name="mpd">MPD support. Needs libmpd installed.</flag>
+ <flag name="mpris">MPRIS v1, v2 support.</flag>
+ <flag name="rtsopts">Use -with-rtsopts=-V0 to reduce wakeups.</flag>
+ <flag name="timezone">Enables localized date support.</flag>
+ <flag name="uvmeter">UVMeter only useful to australians.</flag>
+ <flag name="weather">Enable weather plugin.</flag>
+ <flag name="wifi">Wireless info support via nl80211. Required for the Wireless plugin on systems running Linux, the kernel.</flag>
+ <flag name="xft">Use Xft to render text. UTF-8 support included.</flag>
+ <flag name="xpm">Enable usage of xpm for icons.</flag>
</use>
- <longdescription>
- Xmobar is a minimalistic text based status bar.
-
- Inspired by the Ion3 status bar, it supports similar
- features, like dynamic color management, output templates,
- and extensibility through plugins.
- </longdescription>
</pkgmetadata>
diff --git a/x11-misc/xmobar/xmobar-0.44.1.ebuild b/x11-misc/xmobar/xmobar-0.44.1.ebuild
new file mode 100644
index 000000000000..3a1e2ecbeb3f
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.44.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,-with_iwlib,with_nl80211:wifi,+with_inotify
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="https://codeberg.org/xmobar/xmobar"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus mpd mpris +rtsopts timezone uvmeter +weather wifi xft xpm"
+
+RDEPEND=">=dev-haskell/aeson-1.4.7.1:=[profile?]
+ dev-haskell/async:=[profile?]
+ >=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/parsec-numbers-0.1.0:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.6.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ alsa? ( >=dev-haskell/alsa-core-0.5:=[profile?] <dev-haskell/alsa-core-0.6:=[profile?]
+ >=dev-haskell/alsa-mixer-0.3:=[profile?] <dev-haskell/alsa-mixer-0.4:=[profile?] )
+ dbus? ( >=dev-haskell/dbus-1:=[profile?]
+ weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ xpm? ( x11-libs/libXpm ) )
+ !dbus? ( !uvmeter? ( weather? ( !xpm? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) ) )
+ >=dev-haskell/hinotify-0.3:=[profile?] <dev-haskell/hinotify-0.5:=[profile?]
+ mpd? ( >=dev-haskell/libmpd-0.9.2.0:=[profile?] )
+ mpris? ( >=dev-haskell/dbus-1:=[profile?]
+ !dbus? ( !uvmeter? ( weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) )
+ xpm? ( x11-libs/libXpm
+ weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) )
+ !xpm? ( uvmeter? ( weather? ( dev-haskell/http-client-tls:=[profile?] ) ) ) )
+ !mpris? ( !dbus? ( weather? ( dev-haskell/http-client-tls:=[profile?] )
+ xpm? ( x11-libs/libXpm
+ weather? ( dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) ) )
+ timezone? ( >=dev-haskell/timezone-olson-0.2:=[profile?] <dev-haskell/timezone-olson-0.3:=[profile?]
+ >=dev-haskell/timezone-series-0.1:=[profile?] <dev-haskell/timezone-series-0.2:=[profile?] )
+ uvmeter? ( dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ wifi? ( >=dev-haskell/cereal-0.5.8.1:=[profile?]
+ >=dev-haskell/netlink-1.1.1.0:=[profile?] )
+ xft? ( >=dev-haskell/x11-xft-0.2:=[profile?] <dev-haskell/x11-xft-0.4:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ --flag=-with_iwlib \
+ --flag=with_inotify \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ $(cabal_flag wifi with_nl80211) \
+ $(cabal_flag rtsopts with_rtsopts) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag uvmeter with_uvmeter) \
+ $(cabal_flag weather with_weather) \
+ $(cabal_flag xft with_xft) \
+ $(cabal_flag xpm with_xpm)
+}
+
+src_install() {
+ cabal_src_install
+
+# dodoc readme.md
+ dodoc examples/xmobar.config examples/xmobar.hs changelog.md
+}