summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-30 21:19:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-30 21:19:07 +0000
commit52dcd1a0b28afe53a6f82f4221fee1cecf59dbfb (patch)
tree01c0ada74814ee36237252eefb03355c8f682864 /x11-misc
parentdev-db/mariadb: Version bump for 10.1.44 (diff)
downloadgentoo-52dcd1a0b28afe53a6f82f4221fee1cecf59dbfb.tar.gz
gentoo-52dcd1a0b28afe53a6f82f4221fee1cecf59dbfb.tar.bz2
gentoo-52dcd1a0b28afe53a6f82f4221fee1cecf59dbfb.zip
x11-misc/bbrun: tweak for gcc-10, bug #707448
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/707448 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild3
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-gcc-10.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
index f9bd99cef70b..0ae88b552435 100644
--- a/x11-misc/bbrun/bbrun-1.6-r1.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
src_compile() {
diff --git a/x11-misc/bbrun/files/bbrun-1.6-gcc-10.patch b/x11-misc/bbrun/files/bbrun-1.6-gcc-10.patch
new file mode 100644
index 000000000000..ef23d1152ada
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-gcc-10.patch
@@ -0,0 +1,23 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -70,6 +70,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+diff --git a/wmgeneral/wmgeneral.h b/wmgeneral/wmgeneral.h
+index e9d6ca6..cad4f38 100644
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -36,7 +36,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */