summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/bfm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/bfm')
-rw-r--r--x11-plugins/bfm/Manifest1
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r1.ebuild50
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r2.ebuild43
-rw-r--r--x11-plugins/bfm/files/bfm-0.6.4-makefile.patch66
-rw-r--r--x11-plugins/bfm/metadata.xml9
5 files changed, 169 insertions, 0 deletions
diff --git a/x11-plugins/bfm/Manifest b/x11-plugins/bfm/Manifest
new file mode 100644
index 000000000000..be6da3dcd7e0
--- /dev/null
+++ b/x11-plugins/bfm/Manifest
@@ -0,0 +1 @@
+DIST bfm-0.6.4.tar.bz2 50634 SHA256 e5afb9eaebb67428c441c1eb0a98e5ad1aae46d2dcfe36567f9151c763ca04f9 SHA512 4255e31d1e04bbcd007be7a616184f97b2fb73711c2070859919666685848d75d5641396f206a6a6d70c656cbf8e97357aed3d663dc6d63ed1e7eb426d13f81c WHIRLPOOL 44b73dfe07d30f83aadd9e919dcdc004e60583e00d28df4b6c202db746b571c34cfb0c854536672338e614c61cc9e789b2adc0877bfd45d975b997a7d60f07f2
diff --git a/x11-plugins/bfm/bfm-0.6.4-r1.ebuild b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..2c998aabead8
--- /dev/null
+++ b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
+HOMEPAGE="http://www.jnrowe.ukfsn.org/projects/bfm.html"
+SRC_URI="http://www.jnrowe.ukfsn.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gkrellm"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gkrellm? ( >=app-admin/gkrellm-2 )"
+
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS =:CFLAGS +=:' \
+ -e 's:LDFLAGS =:LDFLAGS +=:' \
+ -e 's:strip:true:' \
+ -e 's:$(CFLAGS) -o $(BUBBLEFISHYMON):$(CFLAGS) $(SRCS) -o $(BUBBLEFISHYMON):' \
+ -e 's:$(LIBS) $(GTK2_LIBS) $(SRCS):$(LIBS) $(GTK2_LIBS):' \
+ -e 's:-o $(BUBBLEFISHYMON):$(GENTOO_LDFLAGS) -o $(BUBBLEFISHYMON):' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
+ use gkrellm && emake gkrellm CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bubblefishymon
+
+ doman doc/*.1
+ dodoc ChangeLog* README* doc/*.sample
+
+ if use gkrellm; then
+ insinto /usr/$(get_libdir)/gkrellm2/plugins
+ doins gkrellm-bfm.so
+ fi
+}
diff --git a/x11-plugins/bfm/bfm-0.6.4-r2.ebuild b/x11-plugins/bfm/bfm-0.6.4-r2.ebuild
new file mode 100644
index 000000000000..2388d35d47aa
--- /dev/null
+++ b/x11-plugins/bfm/bfm-0.6.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
+HOMEPAGE="http://www.jnrowe.ukfsn.org/projects/bfm.html"
+SRC_URI="http://www.jnrowe.ukfsn.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gkrellm"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gkrellm? ( >=app-admin/gkrellm-2 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
+ use gkrellm && emake gkrellm CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bubblefishymon
+
+ doman doc/*.1
+ dodoc ChangeLog* README* doc/*.sample
+
+ if use gkrellm; then
+ insinto /usr/$(get_libdir)/gkrellm2/plugins
+ doins gkrellm-bfm.so
+ fi
+}
diff --git a/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch b/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch
new file mode 100644
index 000000000000..ef47930c5dc5
--- /dev/null
+++ b/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch
@@ -0,0 +1,66 @@
+--- Makefile.orig 2015-01-20 10:56:34.791157688 +0100
++++ Makefile 2015-01-20 10:56:48.135154215 +0100
+@@ -26,21 +26,21 @@
+ EXTRA += $(WMAN)
+
+ # gtk cflags and gtk lib flags
+-GTK_CFLAGS = $(shell gtk-config --cflags)
++GTK_CFLAGS += $(shell gtk-config --cflags)
+ GTK_LIBS = $(shell gtk-config --libs)
+
+-GTK2_CFLAGS = $(shell pkg-config gtk+-2.0 --cflags)
++GTK2_CFLAGS += $(shell pkg-config gtk+-2.0 --cflags)
+ GTK2_LIBS = $(shell pkg-config gtk+-2.0 --libs)
+
+
+ # optimization cflags
+-#CFLAGS = -O3 -Wall ${EXTRA}
+-CFLAGS = ${EXTRA}
++#CFLAGS += -O3 -Wall ${EXTRA}
++CFLAGS += ${EXTRA}
+
+ # profiling cflags
+-# CFLAGS = -ansi -Wall -pg -O3 ${EXTRA} -DPRO
++# CFLAGS += -ansi -Wall -pg -O3 ${EXTRA} -DPRO
+ # test coverage cflags
+-# CFLAGS = -fprofile-arcs -ftest-coverage -Wall -ansi -g ${EXTRA} -DPRO
++# CFLAGS += -fprofile-arcs -ftest-coverage -Wall -ansi -g ${EXTRA} -DPRO
+
+
+ SHELL = sh
+@@ -53,9 +53,9 @@
+ GKRELLM_SRCS = gkrellm-bfm.c
+ GKRELLM_OBJS = gkrellm-bfm.o
+ GKRELLM_BFM = gkrellm-bfm.so
+-LDFLAGS = -shared -Wl
++LDFLAGS += -shared -Wl
+
+-STRIP = strip
++STRIP = true
+
+ CC = gcc
+
+@@ -70,6 +70,7 @@
+ else
+ CFLAGS+=-DNET_DEVICE=\"$(NET_DEVICE)\"
+ endif
++ LIBS = -lm -lX11
+ SRCS += sys_linux.c
+ OBJS += sys_linux.o
+ INSTALL = -m 755
+@@ -129,12 +130,12 @@
+ $(STRIP) $(GKRELLM_BFM)
+
+ bubblefishymon: clean_obj
+- $(CC) $(GTK2_CFLAGS) $(CFLAGS) -o $(BUBBLEFISHYMON) \
+- $(LIBS) $(GTK2_LIBS) $(SRCS)
++ $(CC) $(GTK2_CFLAGS) $(CFLAGS) $(SRCS) $(GENTOO_LDFLAGS) -o $(BUBBLEFISHYMON) \
++ $(LIBS) $(GTK2_LIBS)
+ $(STRIP) $(BUBBLEFISHYMON)
+
+ bubblefishymon1: clean_obj
+- $(CC) $(GTK_CFLAGS) $(CFLAGS) -o $(BUBBLEFISHYMON) \
++ $(CC) $(GTK_CFLAGS) $(CFLAGS) $(SRCS) $(GENTOO_LDFLAGS) -o $(BUBBLEFISHYMON) \
+ $(LIBS) $(GTK_LIBS) $(SRCS)
+ $(STRIP) $(BUBBLEFISHYMON)
+
diff --git a/x11-plugins/bfm/metadata.xml b/x11-plugins/bfm/metadata.xml
new file mode 100644
index 000000000000..70c6e54b08a3
--- /dev/null
+++ b/x11-plugins/bfm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<use>
+ <flag name='gkrellm'>Enable building of <pkg>app-admin/gkrellm</pkg>
+ module</flag>
+</use>
+</pkgmetadata>