summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:27:41 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:27:41 -0400
commitb731c87c096e0bf11ca86b12c63bcf39d89bb1f8 (patch)
treebd0075d334379207bbbaaffd5280d0f06eeadceb /x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild
parentnet-dns/rbldnsd: new revision with EAPI=6 and dropping eutils. (diff)
downloadgentoo-b731c87c096e0bf11ca86b12c63bcf39d89bb1f8.tar.gz
gentoo-b731c87c096e0bf11ca86b12c63bcf39d89bb1f8.tar.bz2
gentoo-b731c87c096e0bf11ca86b12c63bcf39d89bb1f8.zip
x11-plugins/gkrellm-countdown: new revision fixing HOMEPAGE and LDFLAGS.
This new revision fixes two bugs, both thanks to Michael Mair-Keimberger who posted patches to our bugzilla. The first is that the upstream build system did not support LDFLAGS -- it now does, with a patched Makefile. Michael also corrected the invalid HOMEPAGE variable, and added the ~amd64 keyword (which I am able to test). The ebuild has been updated to EAPI=6. Gentoo-Bug: 339657 Gentoo-Bug: 367171 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild b/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..e55f2a699132
--- /dev/null
+++ b/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A simple countdown clock for GKrellM2"
+SRC_URI="http://oss.pugsplace.net/${P}.tar.gz"
+HOMEPAGE="http://freecode.com/projects/gkrellm-countdown"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE=""
+
+COMMON_DEPEND="app-admin/gkrellm[X]"
+RDEPEND+=" ${COMMON_DEPEND}"
+DEPEND+=" ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}