summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2023-06-23 15:44:55 -0600
committerJoonas Niilola <juippis@gentoo.org>2023-07-14 09:52:18 +0300
commit92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f (patch)
tree08b23667077f3d9f0f271bb1ab982e551ff96474 /x11-plugins/pidgin-sipe
parentdev-python/pillow: Add missing dev-python/wheel dep (diff)
downloadgentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.tar.gz
gentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.tar.bz2
gentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.zip
x11-plugins/pidgin-sipe: fix bashisms in configure script
Bug: https://bugs.gentoo.org/730118 Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Closes: https://github.com/gentoo/gentoo/pull/31586 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-sipe')
-rw-r--r--x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch53
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild11
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch
new file mode 100644
index 000000000000..083d41bd0fde
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.25.0-bashisms.patch
@@ -0,0 +1,53 @@
+Fix bashisms in configure script.
+
+Bug: https://bugs.gentoo.org/821451
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -444,10 +444,10 @@
+ [PKG_CHECK_MODULES(_SIPE_MEDIA_RECHECK_PLEASE_IGNORE, [$purple_pkgconfig >= 2.8.0],
+ dnl check purple pkgconfig for gstreamer version
+ [gstreamer_pkgconfig=`$PKG_CONFIG --variable=gstreamer $purple_pkgconfig`
+- AS_IF([test "x$gstreamer_pkgconfig" == x],
+- [AS_IF([test "x$purple_pkgconfig" == xpurple-3],
++ AS_IF([test "x$gstreamer_pkgconfig" = x],
++ [AS_IF([test "x$purple_pkgconfig" = xpurple-3],
+ [gstreamer_pkgconfig=1.0])])
+- AS_IF([test "x$gstreamer_pkgconfig" == x1.0],
++ AS_IF([test "x$gstreamer_pkgconfig" = x1.0],
+ [gstreamer_pkgconfig="gstreamer-$gstreamer_pkgconfig gstreamer-rtp-$gstreamer_pkgconfig"
+
+ AC_MSG_NOTICE([using packages "$gstreamer_pkgconfig".])
+@@ -556,18 +556,18 @@
+ AM_CONDITIONAL(SIPE_WITH_VV, [test "x$with_purple_vv" != xno])
+
+ dnl raw data RTP streams enable Lync file transfer
+-AM_CONDITIONAL(SIPE_HAVE_XDATA, [test "x$ac_have_xdata" == xyes])
+-AS_IF([test "x$ac_have_xdata" == xyes],
++AM_CONDITIONAL(SIPE_HAVE_XDATA, [test "x$ac_have_xdata" = xyes])
++AS_IF([test "x$ac_have_xdata" = xyes],
+ [AC_DEFINE(HAVE_XDATA, 1, [Define if we have raw data RTP in media backend.])])
+
+ dnl enable appshare support
+-AM_CONDITIONAL(SIPE_HAVE_APPSHARE, [test "x$ac_have_appshare" == xyes])
+-AS_IF([test "x$ac_have_appshare" == xyes],
++AM_CONDITIONAL(SIPE_HAVE_APPSHARE, [test "x$ac_have_appshare" = xyes])
++AS_IF([test "x$ac_have_appshare" = xyes],
+ [AC_DEFINE(HAVE_APPSHARE, 1, [Define to 1 if we have appshare support.])])
+
+ dnl RDP server for sharing local desktop
+ AM_CONDITIONAL(SIPE_HAVE_APPSHARE_SERVER, [test "x$ac_have_appshare_server" = xyes])
+-AS_IF([test "x$ac_have_appshare_server" == xyes],
++AS_IF([test "x$ac_have_appshare_server" = xyes],
+ [AC_DEFINE(HAVE_APPSHARE_SERVER, 1, [Define if appshare server is enabled.])])
+
+ dnl libpurple API relies on GParameter (deprecated in glib-2.0 >= 2.62.0)
+@@ -584,7 +584,7 @@
+ [We need GValueArray for which no replacement is available])
+ ])
+ dnl libpurple 2.x API relies on G_CONST_RETURN (deprecated in glib-2.0 >= 2.30.0)
+-AS_IF([test "x$purple_pkgconfig" == xpurple],
++AS_IF([test "x$purple_pkgconfig" = xpurple],
+ [AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_28,
+ [libpurple 2.x API uses G_CONST_RETURN])
+ ])
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
index 4b73a6e3e9c1..bbdf8d917086 100644
--- a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,6 +7,8 @@ DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
HOMEPAGE="http://sipe.sourceforge.net/"
SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+inherit autotools
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
@@ -43,6 +45,13 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.25.0-bashisms.patch
+
+ eautoreconf
+ default
+}
+
src_configure() {
local myeconfargs=(
--enable-purple