summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 18:19:05 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:28 +0200
commit5bc50765fb21c661dd04c845c932dbc11bb0a562 (patch)
treecc50470b68f9a1866fa84838a057901ea12a6894 /x11-plugins/wmbio
parentx11-plugins/wmacpimon: EAPI8 bump, fix calling cc directly (diff)
downloadgentoo-5bc50765fb21c661dd04c845c932dbc11bb0a562.tar.gz
gentoo-5bc50765fb21c661dd04c845c932dbc11bb0a562.tar.bz2
gentoo-5bc50765fb21c661dd04c845c932dbc11bb0a562.zip
x11-plugins/wmbio: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmbio')
-rw-r--r--x11-plugins/wmbio/wmbio-1.02-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmbio/wmbio-1.02-r1.ebuild b/x11-plugins/wmbio/wmbio-1.02-r1.ebuild
new file mode 100644
index 000000000000..612f5ae35117
--- /dev/null
+++ b/x11-plugins/wmbio/wmbio-1.02-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Window Maker applet that shows your biorhythm"
+HOMEPAGE="https://wmbio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wmbio/${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare() {
+ default
+ # Honour Gentoo CFLAGS, LDFLAGS, CC
+ sed -i -e "s/-g -O2/\$(CFLAGS)/" \
+ -e "s/-o wmbio/\$(LDFLAGS) -o wmbio/" \
+ -e "s/cc /\$(CC) /" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmbio
+ dodoc ../{AUTHORS,Changelog,NEWS,README}
+}