summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:28:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:05 -0400
commit4503279508de491f424ef741fb47098153e8980f (patch)
treec61f0f7aa2ef65fa72ab43ac4d21dbc9eacb751c /x11-plugins
parentx11-plugins/asmem: pass -std=gnu89 (diff)
downloadgentoo-4503279508de491f424ef741fb47098153e8980f.tar.gz
gentoo-4503279508de491f424ef741fb47098153e8980f.tar.bz2
gentoo-4503279508de491f424ef741fb47098153e8980f.zip
x11-plugins/wmnet: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
index 21e339edf295..0df8301f1ddb 100644
--- a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
+++ b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="WMnet is a dock.app network monitor"
HOMEPAGE="https://www.dockapps.net/wmnet"
@@ -28,6 +28,8 @@ BDEPEND="
PATCHES=( "${WORKDIR}"/${P}-misc.patch )
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die "xmkmf failed"
}