summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-30 08:31:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-30 08:51:01 +0200
commitbd5f60169a0e2fa81aa39dea21ffff1eaebdc4ef (patch)
tree2660374e0a15a197ed2a17213b5b4d3299c7cb8f /x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild
parentxfce-extra/xfce4-pulseaudio-plugin: Bump to 0.4.3 (diff)
downloadgentoo-bd5f60169a0e2fa81aa39dea21ffff1eaebdc4ef.tar.gz
gentoo-bd5f60169a0e2fa81aa39dea21ffff1eaebdc4ef.tar.bz2
gentoo-bd5f60169a0e2fa81aa39dea21ffff1eaebdc4ef.zip
x11-terms/xfce4-terminal: Bump to 0.8.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild')
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild
new file mode 100644
index 000000000000..81501fe3e7f1
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="https://docs.xfce.org/apps/terminal/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter"
+
+RDEPEND=">=dev-libs/glib-2.38:2=
+ >=x11-libs/gtk+-3.20.8:3=
+ x11-libs/libX11:=
+ >=x11-libs/vte-0.38:2.91=
+ >=xfce-base/libxfce4ui-4.10:=[gtk3(+)]
+ utempter? ( sys-libs/libutempter:= )"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS )
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ )
+
+ econf "${myconf[@]}"
+}