summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 01:29:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 01:33:13 -0400
commit52a6153599d63ec242015add29c8f58888316849 (patch)
tree967cc6b7b6e07e14846a2c734853212984464777 /x11-terms
parentx11-terms/kitty-shell-integration: add 0.36.4 (diff)
downloadgentoo-52a6153599d63ec242015add29c8f58888316849.tar.gz
gentoo-52a6153599d63ec242015add29c8f58888316849.tar.bz2
gentoo-52a6153599d63ec242015add29c8f58888316849.zip
x11-terms/kitty: add 0.36.4
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.36.4.ebuild187
2 files changed, 190 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index e64a2d7faaa2..540990c977af 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -7,3 +7,6 @@ DIST kitty-0.36.2.tar.xz.sig 566 BLAKE2B 03d75daa5163ac352210d8cd65b528b0cd558e9
DIST kitty-0.36.3-vendor.tar.xz 1563672 BLAKE2B 297b6de50431356c153c2464c33ff206be416215277dbb00849d4a6100318803dd13851e6f682487beddc5b3abd8aae5994ef5448573566808c6b328542fc3d0 SHA512 463a550bbeed52ece4eb804d8a30115f3368a79f8ff907fe64e93e3a93340485b1110d021364d149c425318c80f46f31d65ddb1b99bf9fc579f8a42689aacefa
DIST kitty-0.36.3.tar.xz 8836304 BLAKE2B 0ed7c8ea92c8fedae64a1059b21f120fab3141607be27c74116f34ee637fc33899dc240954d47757f36ec487bba40f7856423777d756014a3dd5221329403293 SHA512 290ce8d1d64ed431221ecdc9f942218ee375d7c065193186ad3d2a58bb936ff206b6df3379cd0d4d233cbf3433f9fbeb16d0459704e343cb32305de841828513
DIST kitty-0.36.3.tar.xz.sig 566 BLAKE2B ddcce94836b61f33755321dd4fccdedc188e5ff43aa3703aaf3369ab22851ad105d821a0245abadbc775288a7141280d4494391174d507bc65eb5c890a8ddcef SHA512 0d3f069ae8f3adf86101d91926bb0c665e72db4bc9ab0cc4a736d735aea702b2a4d5995dba58ead01127cbfb54bbf7d8763b702515306c6eb5444612f317732b
+DIST kitty-0.36.4-vendor.tar.xz 1563664 BLAKE2B f51f8360e40a4accc504444e1f681b126a9e7d93e75d25f01284f744489fd9cb7ea9ba439136d0fe291d71eee2f05efe5f4cec0c5a94552753da522bdf60c7a8 SHA512 b0a39549a6d1e90fc0b36fdddbcfcf1f8f41c03b5457b92717be3f2f2747ec75fb04a0fcd7394510616de7da3ebb33fc0cbcd1483f4419edd750bfce6788dce5
+DIST kitty-0.36.4.tar.xz 8875060 BLAKE2B 530b11a719360997230ef12dc857dea975ccfce1f111c23ccabf392bd463ebe3ae80aef8cb8a1f7c3877e7847d750ad04f6185c0d8e05ac9770f2b7dfc407bf5 SHA512 3ffabb181903495d6a11a8b790e75331a5ab0986de0b7a7958ea7dfee724c29aee88c31672e2f7711d3fc51a81e1a3c84e4469228872aa62df840ded2c0d5218
+DIST kitty-0.36.4.tar.xz.sig 566 BLAKE2B 94f7bc5dd8c121cd9f10b06a3e0644bfb30e9f66716999fee3a2bab302f8f79965e2c3cce000a074424d84ac902db4784600416afba51e7bad90dc2f66a5580b SHA512 14c629f01e5f92d06388fb0effd256447ee24f1a24492a5478091745c7a5ebe839be70be053652b0329b85d78ef471ce6b34c46c2d4b3bddf8ea8ba9281d4e6d
diff --git a/x11-terms/kitty/kitty-0.36.4.ebuild b/x11-terms/kitty/kitty-0.36.4.ebuild
new file mode 100644
index 000000000000..5b29cd01b6e8
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.36.4.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-fonts/symbols-nerd-font
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.23:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+
+ # kitty currently detects and copies the system's nerd font at build
+ # time, then uses that rather than the system's at runtime
+ dosym -r /usr/share/fonts/symbols-nerd-font/SymbolsNerdFontMono-Regular.ttf \
+ /usr/"$(get_libdir)"/kitty/fonts/SymbolsNerdFontMono-Regular.ttf
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ use X && optfeature "X11 startup notification support" x11-libs/startup-notification
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}