summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-21 11:43:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-21 11:47:46 +0100
commit12a83dec8720fda064994e46557fd3d1291a245b (patch)
tree7bedb0f09de09c045751bfe706558615b0d9ea1a /x11-wm/qtile
parentapp-portage/pycargoebuild: Remove old (diff)
downloadgentoo-12a83dec8720fda064994e46557fd3d1291a245b.tar.gz
gentoo-12a83dec8720fda064994e46557fd3d1291a245b.tar.bz2
gentoo-12a83dec8720fda064994e46557fd3d1291a245b.zip
x11-wm/qtile: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-wm/qtile')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/qtile-0.22.1-r3.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index ffef237185f4..5908b4193b7e 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,2 +1 @@
-DIST qtile-0.22.1.tar.gz 488969 BLAKE2B 3b2fce587ae39570997b503cb386314160dbefa39b1ef65dc2ff5bc2f1167251224a0f298ef8e374d0d4c034d1e5012251f96b92ce5cb74d7fd93320e14ff8bf SHA512 944ec27b5d227154624fa2a15a0840b748307a1e79ab52ccf3384763111459b3c4d26b4677f8e2ea51634206dc6d1e32e057e057db917b3705ce583d83a8056d
DIST qtile-0.23.0.tar.gz 524536 BLAKE2B 9cf5b0cdffd7bc95ab7649827c221b20718f9dcc19b8ae2a50ceac5df3d71b117eef493a40523d81e60c8bc54b2103bc2a93775fcb20c025ec1dd84f9d809a19 SHA512 d6886df8efefacf90b1a5ec487c9a5a90414593900159213a218d638ef4f018b69284fe2cea707da12655a9736aad3df74a338a60344536e4d7eebcc9fc1090b
diff --git a/x11-wm/qtile/qtile-0.22.1-r3.ebuild b/x11-wm/qtile/qtile-0.22.1-r3.ebuild
deleted file mode 100644
index 62974989e46e..000000000000
--- a/x11-wm/qtile/qtile-0.22.1-r3.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
-HOMEPAGE="http://qtile.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/qtile/qtile.git"
-else
- inherit pypi
- KEYWORDS="amd64 ~riscv ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="pulseaudio wayland"
-
-# See bug #895722 and https://github.com/qtile/qtile/pull/3985 regarding
-# pywlroots-0.15 dep.
-# xcffib v1.4.0 breaks its ffi export (https://github.com/qtile/qtile/pull/4289)
-RDEPEND="
- <dev-python/cairocffi-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
- dev-python/dbus-next[${PYTHON_USEDEP}]
- dev-python/pygobject[${PYTHON_USEDEP}]
- <dev-python/xcffib-1.4.0[${PYTHON_USEDEP}]
- x11-libs/cairo[X,xcb(+)]
- x11-libs/libnotify[introspection]
- x11-libs/pango
- pulseaudio? (
- media-sound/pulseaudio
- )
- wayland? (
- =dev-python/pywlroots-0.15*[${PYTHON_USEDEP}]
- )
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- media-gfx/imagemagick[X]
- x11-base/xorg-server[xephyr]
- )
-"
-
-EPYTEST_DESELECT=(
- # Can't find built qtile like migrate
- test/test_qtile_cmd.py::test_qtile_cmd
- test/test_qtile_cmd.py::test_display_kb
-)
-
-EPYTEST_IGNORE=(
- # Tries to find binary and fails; not worth running anyway?
- test/test_migrate.py
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid automagic dependency on libpulse
- if ! use pulseaudio ; then
- sed -i -e "s/call('libpulse', '--libs')/raise PkgConfigError/" setup.py || die
-
- # TODO: use this sed for next release after 0.22.1, quoting changed
- # sed -i -e 's/call("libpulse", "--libs")/throw PkgConfigError/' setup.py || die
- fi
-
- # Avoid automagic dependency on pywlroots
- if ! use wayland ; then
- sed -i -e 's/import wlroots.ffi_build/raise ImportError/' setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- # Force usage of built module
- rm -rf "${S}"/libqtile || die
-
- # TODO: remove "-p no:xdist" for next release when https://github.com/qtile/qtile/issues/1634 will be resolved.
- epytest -p no:xdist --backend=x11 $(usev wayland '--backend=wayland') || die "Tests failed with ${EPYTHON}"
-}
-
-python_compile() {
- export CFFI_TMPDIR=${T}
- distutils-r1_python_compile
-}
-
-python_install_all() {
- local DOCS=( CHANGELOG README.rst )
- distutils-r1_python_install_all
-
- insinto /usr/share/xsessions
- doins resources/qtile.desktop
-
- insinto /usr/share/wayland-sessions
- doins resources/qtile-wayland.desktop
-
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
-}