summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEgor Martynov <martynovegorOF@yandex.ru>2023-02-23 17:45:35 +0700
committerSam James <sam@gentoo.org>2023-02-23 13:40:17 +0000
commitdff5e674d0b9e0875bb80773178e4b70738dbcb3 (patch)
tree18957433e5b32db8c50d87e1a0f9530cce2dfb08 /x11-wm/qtile
parentsys-devel/clang: Fix automagic dep on HSA runtime (diff)
downloadgentoo-dff5e674d0b9e0875bb80773178e4b70738dbcb3.tar.gz
gentoo-dff5e674d0b9e0875bb80773178e4b70738dbcb3.tar.bz2
gentoo-dff5e674d0b9e0875bb80773178e4b70738dbcb3.zip
x11-wm/qtile: depend on pywlroots-0.15.x versions
Bug: https://github.com/qtile/qtile/pull/3985 Closes: https://bugs.gentoo.org/895722 Signed-off-by: Egor Martynov <martynovegorOF@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/qtile')
-rw-r--r--x11-wm/qtile/qtile-0.22.1-r1.ebuild4
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild8
2 files changed, 8 insertions, 4 deletions
diff --git a/x11-wm/qtile/qtile-0.22.1-r1.ebuild b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
index b977e32eec6b..558b0bda0dee 100644
--- a/x11-wm/qtile/qtile-0.22.1-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
@@ -23,6 +23,8 @@ LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio wayland"
+# See bug #895722 and https://github.com/qtile/qtile/pull/3985 regarding
+# pywlroots-0.15 dep.
RDEPEND="
>=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
@@ -37,7 +39,7 @@ RDEPEND="
media-sound/pulseaudio
)
wayland? (
- dev-python/pywlroots[${PYTHON_USEDEP}]
+ =dev-python/pywlroots-0.15*[${PYTHON_USEDEP}]
)
"
BDEPEND="
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index 871b161d1af7..02efe955cdc0 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -16,13 +16,15 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/qtile/qtile.git"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio wayland"
+# See bug #895722 and https://github.com/qtile/qtile/pull/3985 regarding
+# pywlroots-0.15 dep.
RDEPEND="
>=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
@@ -37,7 +39,7 @@ RDEPEND="
media-sound/pulseaudio
)
wayland? (
- dev-python/pywlroots[${PYTHON_USEDEP}]
+ =dev-python/pywlroots-0.15*[${PYTHON_USEDEP}]
)
"
BDEPEND="
@@ -83,7 +85,7 @@ python_test() {
# Force usage of built module
rm -rf "${S}"/libqtile || die
- # TODO: remove "-p no:xdist" when https://github.com/qtile/qtile/issues/1634 will be resolved.
+ # TODO: remove "-p no:xdist" for next release when https://github.com/qtile/qtile/issues/1634 will be resolved.
epytest -p no:xdist --backend=x11 $(usev wayland '--backend=wayland') || die "Tests failed with ${EPYTHON}"
}