summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-01 07:30:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-01 08:13:07 +0200
commit4419b963ac10eae1e52920f8254aad8b137fccc6 (patch)
treeddf5c2b3ca5d20ac112ff46f4a14a39cedd1c6c8 /xfce-extra/thunar-archive-plugin
parentdev-python/pgspecial: Bump to 2.1.0 (diff)
downloadgentoo-4419b963ac10eae1e52920f8254aad8b137fccc6.tar.gz
gentoo-4419b963ac10eae1e52920f8254aad8b137fccc6.tar.bz2
gentoo-4419b963ac10eae1e52920f8254aad8b137fccc6.zip
xfce-extra/thunar-archive-plugin: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index 32e8d4aa5936..016aac998b13 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-archive-plugin-0.5.0.tar.bz2 378749 BLAKE2B d420e121351fc78bd67880c89574a762dfd51949087cbde117c48cf8f879bf1c7416d960bf7d49bb704008a8dc10e1d87ecf43481f644f07bbadbc00d7348af8 SHA512 5a606f5102689e5e0fa051b25cae6f66248491aeab2c6402fd158151f9cbfab54ff4b61c36eab89fdf323b65065d955bdedd6760f32a5493179e92492ee1df37
+DIST thunar-archive-plugin-0.5.1.tar.bz2 369808 BLAKE2B 4a548f2249c5fe84e797759a6d6ac28f3ad0dbdc1361950e2593be55541500e5937b34d0408b3c66a1b964d58b2c2fe4c012a323d46defb4b3f56ec1442d229e SHA512 e79c60d42a3c40007b361fca918977a84c6f8737136f06b0ef073ce574731162fc2145d2563d751b3cf73222e38361aa1ef6435eec90fce7d86d43102e674051
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.1.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.1.ebuild
new file mode 100644
index 000000000000..474e6fb27bd4
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/archive
+ https://gitlab.xfce.org/thunar-plugins/thunar-archive-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}