summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-22 18:34:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-22 18:36:40 +0200
commitee1608f816ad88fe3709f9b71949d3fda41ad3dd (patch)
tree5c36e127f07ef95e1d1d848379384a134e6d3825 /xfce-extra/xfce4-dict
parentmedia-sound/xfmpc: Bump to 0.3.1 (diff)
downloadgentoo-ee1608f816ad88fe3709f9b71949d3fda41ad3dd.tar.gz
gentoo-ee1608f816ad88fe3709f9b71949d3fda41ad3dd.tar.bz2
gentoo-ee1608f816ad88fe3709f9b71949d3fda41ad3dd.zip
xfce-extra/xfce4-dict: Bump to 0.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-dict')
-rw-r--r--xfce-extra/xfce4-dict/Manifest1
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/Manifest b/xfce-extra/xfce4-dict/Manifest
index 465f75df34f5..7deec85f74ff 100644
--- a/xfce-extra/xfce4-dict/Manifest
+++ b/xfce-extra/xfce4-dict/Manifest
@@ -1 +1,2 @@
DIST xfce4-dict-0.8.4.tar.bz2 526227 BLAKE2B da8ade9ad62dfa086c1550868d28883c1a87e90839d164f52abe92189c62981b0e3b33fc428b805d608871e1c5afb0ec9df94d5239eeeed15e16372b2592e1df SHA512 f662b94671f2179cc93010e9ff6ad7f3425cfafeb8d7c635fefb8e816d78273f0135d6c7ff3ed143e5e01985eb4275ac89827d197ed059fbfa79df69b327f253
+DIST xfce4-dict-0.8.5.tar.bz2 514096 BLAKE2B 5ababf17457fe972794e1aca0a4c031af8c3898e97d46d3d4ba26a0b24bcaa750255dbb084157525650f91a19de8aca9437fa662f70e2340d43b0ab6ae935ebb SHA512 4ff6e881c4dfec6cc6a2e9a33ccad1362d3304e58d91cc5da9305a937c7e3382d9c2ad3356d9e4d5f080d4368f7e0f3ceded1c2fbf18bca8ac7903310d22ffc3
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.5.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.5.ebuild
new file mode 100644
index 000000000000..264838b8e419
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-dict/start
+ https://gitlab.xfce.org/apps/xfce4-dict/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.24.0
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10.0:=
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/xfce4-panel-4.10.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}