summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-11 12:36:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 13:44:25 +0200
commit66c0180782a703f0daa5153bf4efd509d6d6207f (patch)
treee49eb536e1ec4f6578b09bdf9e76e26be0196d81 /xfce-extra/xfce4-volumed-pulse
parentxfce-extra/xfce4-mixer: drop 4.18.0, 4.18.1 (diff)
downloadgentoo-66c0180782a703f0daa5153bf4efd509d6d6207f.tar.gz
gentoo-66c0180782a703f0daa5153bf4efd509d6d6207f.tar.bz2
gentoo-66c0180782a703f0daa5153bf4efd509d6d6207f.zip
xfce-extra/xfce4-volumed-pulse: EAPI 8, switch to media-libs/libpulse
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-volumed-pulse')
-rw-r--r--xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.3-r1.ebuild b/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..001ce97a8d2b
--- /dev/null
+++ b/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Daemon to control volume up/down and mute keys for pulseaudio"
+HOMEPAGE="https://gitlab.xfce.org/apps/xfce4-volumed-pulse/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ppc ~ppc64 ~riscv x86"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.16:2=
+ dev-libs/keybinder:3=
+ media-libs/libpulse:=[glib]
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/xfconf-4.8:=
+ libnotify? ( x11-libs/libnotify:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}