summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-17 19:31:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-17 19:32:43 +0100
commit71c6aba94c393608751903c2e7fe35a441800302 (patch)
tree8bbde6949949efcca657362eca22fe6d6796c33c /xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild
parentapp-metrics/prometheus: add 2.37.5 (diff)
downloadgentoo-71c6aba94c393608751903c2e7fe35a441800302.tar.gz
gentoo-71c6aba94c393608751903c2e7fe35a441800302.tar.bz2
gentoo-71c6aba94c393608751903c2e7fe35a441800302.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild
new file mode 100644
index 000000000000..e781784c425e
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake xdg-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl
+ x11-libs/gtk+:3
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# upstream does fancy stuff in other build types
+CMAKE_BUILD_TYPE=Debug
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ -DENABLE_LINK_TIME_OPTIMIZATION=OFF
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}