summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/jasper/Manifest1
-rw-r--r--media-libs/jasper/jasper-2.0.10.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/jasper/Manifest b/media-libs/jasper/Manifest
index f11d2ea14bb2..5ff6e3bb4b0c 100644
--- a/media-libs/jasper/Manifest
+++ b/media-libs/jasper/Manifest
@@ -1,2 +1,3 @@
DIST jasper-1.900.6.tar.gz 787271 SHA256 5d0b4d684d19104b4564ef7142f4059eda91902620af36a3a6205d3dae66e027 SHA512 096e77609bf977eb0bbc9b1fc804bce7be1c7c81d066db7e367b61c4f6fa772a7a7ef21f7613485de46c3ca22cce57dce1e80c3736f54eb77eb44153218983b6 WHIRLPOOL 23edd5abc05248b43085f5a77a0210dcaf52089c57e31686478bd9b01284f294459ac1cad71eae4a594ef2632ba4323190b25d1a37dd36af0c0d7cd69579e568
+DIST jasper-2.0.10.tar.gz 1310613 SHA256 d48193de3b82e7f5792fe933fba2ef6714228de4d904ce98f3d69217ed7a85ec SHA512 8f96f72b73197088ff28364c7b4db79745a3188aa9be888ad3b211541bb4d1e45f23604b36d0b6c4176a432c2da888d1e31f119279aaab73e09430699e036859 WHIRLPOOL 37f98278af2baf2978b21a894c618166b4086c744c21ce953bad1b7aec9191550eda7d161aa93533c6a8f36399160633de5ea912e5d1e7ac37d5b3eece48062b
DIST jasper-2.0.8.tar.gz 1309946 SHA256 ebaca7b4bb2354c58f649c6d97d07f14292df31666a7cb29f2b4a066976535e4 SHA512 7e77853e96c50b13c356e8ae257f5816cec9e26fa4991b61ad3dc80a7abfd11c742ae21293e4ff5888364b2950a338a4e804338cef66b781fcb863374e679cf0 WHIRLPOOL 0db74aedc2a30392770cfa3eecde063d9566d30f54eea21d796559d85e2ce96f42fe8737aae2202688b80246756373f6b41197e016c5cb40a6a49933639021b5
diff --git a/media-libs/jasper/jasper-2.0.10.ebuild b/media-libs/jasper/jasper-2.0.10.ebuild
new file mode 100644
index 000000000000..fc05fb537ed0
--- /dev/null
+++ b/media-libs/jasper/jasper-2.0.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
+HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 \
+ ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux \
+ ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+# We limit memory usage to 128 MiB by default, specified in bytes
+: ${JASPER_MEM_LIMIT:=134217728}
+
+LICENSE="JasPer2.0"
+SLOT="0/4"
+IUSE="doc jpeg opengl"
+
+RDEPEND="
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
+ >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DALLOW_IN_SOURCE_BUILD=OFF
+ -DBASH_PROGRAM="${EPREFIX}"/bin/bash
+ -DJAS_ENABLE_ASAN=OFF
+ -DJAS_ENABLE_LSAN=OFF
+ -DJAS_ENABLE_MSAN=OFF
+ -DJAS_ENABLE_SHARED=ON
+ -DJAS_ENABLE_STRICT=ON
+ -DJAS_ENABLE_USAN=OFF
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+
+ # JPEG
+ -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
+ -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
+
+ # OpenGL
+ -DJAS_ENABLE_OPENGL=$(usex opengl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
+
+ # Doxygen
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
+ )
+ cmake-utils_src_configure
+}