summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild25
-rw-r--r--sys-apps/dchroot/files/dchroot-0.12.1-make.patch16
-rw-r--r--sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch13
3 files changed, 24 insertions, 30 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index 7f02674ae0ae..fef8cb146e1d 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,36 +1,27 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit toolchain-funcs
+inherit autotools
DESCRIPTION="Utility for managing chroots for non-root users"
-HOMEPAGE="https://packages.debian.org/unstable/admin/dchroot"
-SRC_URI="mirror://debian/pool/main/d/dchroot/dchroot_${PV}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P/-/_}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="sys-apps/help2man"
RDEPEND="!dev-util/schroot[dchroot]"
+BDEPEND="sys-apps/help2man"
PATCHES=(
- "${FILESDIR}"/${PN}-0.12.1-no-werror.patch
+ "${FILESDIR}"/${P}-make.patch
)
src_prepare() {
- sed -i \
- -e '/^all:/s:$: docs:' \
- -e '/^CFLAGS/s:-O2:@CFLAGS@:' \
- -e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
- Makefile.in || die "sed failed"
-
default
-}
-src_compile() {
- emake CC="$(tc-getCC)"
+ eautoreconf #874318
}
diff --git a/sys-apps/dchroot/files/dchroot-0.12.1-make.patch b/sys-apps/dchroot/files/dchroot-0.12.1-make.patch
new file mode 100644
index 000000000000..1c6be7a65c91
--- /dev/null
+++ b/sys-apps/dchroot/files/dchroot-0.12.1-make.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/722920
+https://bugs.gentoo.org/824542
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -4,8 +4,9 @@
+
+ INSTALL=install
+-CFLAGS=-Wl,-z,now -O2 -Wall -Wstrict-prototypes -Werror -g \
++CC := @CC@
++CFLAGS := @CFLAGS@ @CPPFLAGS@ @LDFLAGS@ \
+ -DDCHROOT_VERSION="\"@DCHROOT_VERSION@\""
+
+-all: dchroot
++all: dchroot docs
+
+ docs: dchroot.1
diff --git a/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch b/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
deleted file mode 100644
index 4cd270190456..000000000000
--- a/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/824542
-https://bugs.gentoo.org/722920
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -3,7 +3,7 @@ mandir = ${prefix}/share/man
- sysconfdir = $(DESTDIR)/etc
-
- INSTALL=install
--CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes -Werror -g \
-+CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes \
- -DDCHROOT_VERSION="\"@DCHROOT_VERSION@\""
-
- all: dchroot docs