summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pymssql/Manifest1
-rw-r--r--dev-python/pymssql/files/pymssql-2.1.3-remove-setuptools_git.patch10
-rw-r--r--dev-python/pymssql/pymssql-2.1.5.ebuild34
3 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pymssql/Manifest b/dev-python/pymssql/Manifest
index e8a27b1ffdfa..3e2a7bacc5fd 100644
--- a/dev-python/pymssql/Manifest
+++ b/dev-python/pymssql/Manifest
@@ -1,2 +1 @@
-DIST pymssql-2.1.5.tar.gz 167928 BLAKE2B c94fc29fa9d83627dbee05095a7c0d6e4e2d42ac34b0e6801bbc757d89728aee409c98519d6e8bfe8d5009f06f88bd23a3e62c050f2c964cb7139bdd3185a0b5 SHA512 7cc7336d4c2fcb7c3958fb3127801e3505fd93259d1aaef40a67941ef5aa519e285cdb04fd378c9712f29b0f8a25ce1747a4a8dc21ec57b004c9f0ceb8f5afab
DIST pymssql-2.2.1.tar.gz 170421 BLAKE2B 0bd57ffef97f6a557bf78056ed0f184c3b5de09fa031f80f1b7420486bb137ba1750c2ac63e89c0476a3b1808e08beb037b2d9c3fce89bce98a266626222b5c7 SHA512 d44fbe506d7daf3b5fc1dfa20b99814aa3ed025cf8e4e14097f53014bc21918e0969e15149fa93c39367a06567502be08bb673e30ebdf87d6fc2c30b01216b7c
diff --git a/dev-python/pymssql/files/pymssql-2.1.3-remove-setuptools_git.patch b/dev-python/pymssql/files/pymssql-2.1.3-remove-setuptools_git.patch
deleted file mode 100644
index 1a35cc064f78..000000000000
--- a/dev-python/pymssql/files/pymssql-2.1.3-remove-setuptools_git.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -472,7 +472,6 @@ setup(
- "Operating System :: Unix",
- ],
- zip_safe = False,
-- setup_requires=['setuptools_git'],
- tests_require=['pytest', 'unittest2'],
- ext_modules = ext_modules(),
-
diff --git a/dev-python/pymssql/pymssql-2.1.5.ebuild b/dev-python/pymssql/pymssql-2.1.5.ebuild
deleted file mode 100644
index 0c605034ed92..000000000000
--- a/dev-python/pymssql/pymssql-2.1.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Simple MSSQL python extension module"
-HOMEPAGE="https://www.pymssql.org/ https://pypi.org/project/pymssql/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="test"
-
-# tests need a running instance of freetds
-RESTRICT="test"
-
-RDEPEND=">=dev-db/freetds-0.63[mssql]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.1.3-remove-setuptools_git.patch )
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}