summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild4
-rw-r--r--sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch12
2 files changed, 16 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
index 4beb16299f8c..7de12b4067d1 100644
--- a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
@@ -31,6 +31,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.11.21-unistd.patch"
+)
+
src_configure() {
local -a mycmakeargs=(
-DNOBREAKID=ON
diff --git a/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch b/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch
new file mode 100644
index 000000000000..c64228a17862
--- /dev/null
+++ b/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch
@@ -0,0 +1,12 @@
+index f0a9e33..85286be 100644
+--- a/src/picosat/picosat.c
++++ b/src/picosat/picosat.c
+@@ -8148,7 +8148,7 @@ picosat_stats (PS * ps)
+ #else
+ #include <sys/time.h>
+ #include <sys/resource.h>
+-#include <sys/unistd.h>
++#include <unistd.h>
+ #endif
+
+ double