summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/scientificpython/Manifest2
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.1.ebuild84
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.3.ebuild70
3 files changed, 0 insertions, 156 deletions
diff --git a/dev-python/scientificpython/Manifest b/dev-python/scientificpython/Manifest
index a3ffbf9380d5..e3bee7720e87 100644
--- a/dev-python/scientificpython/Manifest
+++ b/dev-python/scientificpython/Manifest
@@ -1,3 +1 @@
-DIST ScientificPython-2.9.1.tar.gz 595239 SHA256 b45305b03d8238fe1be74d6bbd5541d452d9705ab15069dcd506d38e137e9c5c SHA512 08c609d9204088fa1f9a2563f5321ed7e248469e44c86b5d5bc56dc3f975854c4e2b266a8e750fbdc858ed58a466487da4fe986c15a077319ab1a73d8e9b0305 WHIRLPOOL b731e0aaac972c118519cea9b9076cb449294c3929b4f7baceda69293a1a5c153952b5e46b54e111d1bcdcb2f1ea05162141c8c1f88d284071a7a341218b730d
-DIST ScientificPython-2.9.3.tar.gz 689431 SHA256 a4dfc55c2ec84a0795b0641e5571b79b25a5ef6d92bbb01e934c298ee34b5bc8 SHA512 8633726c8a05f45ac4262dd52213c2dc10148a03b67364d4e50d57953ca410a596f9ba64ee68d3b058dcdc1e7decab21c8b8e9b58e5ac1cf5049cb4588117fa8 WHIRLPOOL 2a7d47770dd1ec7b6eadc85ebdd10ad40f6f3eca873cfc3f4937fdf678d697ac5947e7af9b8caf866b4fe0efb7a2746e684ff8d5775f4f53aafddaed6d110c23
DIST ScientificPython-2.9.4.tar.gz 688704 SHA256 c397fedf76500dc4c010785a82204a45ee51a04a54fabfb6142d594de14f8639 SHA512 8bd3ce3ead090832582711c25f7d4c7a5a55642ef9a1e845fb68b4b3dba833ba86baf9c444fd9948ce761a5357dbf388a2c1a860a66ee13fdf1f26d1010cc8c8 WHIRLPOOL 7890b534cffa53f258a5db8aa974805055773dc9be5ee9862e9c66f7c07df52e2abb36cc30a07e9bb9c8ee61183f44336643191f41e757ce31fa63773b0df8de
diff --git a/dev-python/scientificpython/scientificpython-2.9.1.ebuild b/dev-python/scientificpython/scientificpython-2.9.1.ebuild
deleted file mode 100644
index 90b402ad7ff1..000000000000
--- a/dev-python/scientificpython/scientificpython-2.9.1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils eutils
-
-MY_PN="ScientificPython"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Scientific Module for Python"
-DOWNLOAD_NUMBER="3420"
-SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
-HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
-
-LICENSE="CeCILL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc mpi test"
-
-RDEPEND="
- <dev-python/numpy-1.9
- dev-python/pyro:3
- sci-libs/netcdf
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-PYTHON_MODNAME="Scientific"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.9-mpi.patch"
- use mpi && epatch "${FILESDIR}/${P}-mpi-netcdf.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use mpi; then
- cd Src/MPI
- building_of_mpipython() {
- PYTHONPATH="$(ls -d ../../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" compile.py
- mv -f mpipython mpipython-${PYTHON_ABI}
- }
- python_execute_function \
- --action-message 'Building of mpipython with $(python_get_implementation) $(python_get_version)' \
- --failure-message 'Building of mpipython failed with $(python_get_implementation) $(python_get_version)' \
- building_of_mpipython
- fi
-}
-
-src_test() {
- cd Tests
- python_execute_nosetests -P '$(ls -d ../build-${PYTHON_ABI}/lib.*)'
-}
-
-src_install() {
- distutils_src_install
- # do not install bsp related stuff, since we don't compile the interface
- dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
- insinto /usr/share/doc/${PF}
- doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
-
- if use mpi; then
- installation_of_mpipython() {
- dobin Src/MPI/mpipython-${PYTHON_ABI}
- }
- python_execute_function -q installation_of_mpipython
- python_generate_wrapper_scripts "${ED}usr/bin/mpipython"
- doins Examples/mpi.py || die "doins mpi example failed failed"
- fi
-
- if use doc; then
- dohtml Doc/Reference/* || die "dohtml failed"
- fi
-}
diff --git a/dev-python/scientificpython/scientificpython-2.9.3.ebuild b/dev-python/scientificpython/scientificpython-2.9.3.ebuild
deleted file mode 100644
index 805e26d45d4b..000000000000
--- a/dev-python/scientificpython/scientificpython-2.9.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="ScientificPython"
-MY_P="${MY_PN}-${PV}"
-DOWNLOAD_NUMBER=4425
-
-DESCRIPTION="Scientific Module for Python"
-SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
-HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
-
-LICENSE="CeCILL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc mpi test"
-
-RDEPEND="
- <dev-python/numpy-1.9[${PYTHON_USEDEP}]
- dev-python/pyro:3[${PYTHON_USEDEP}]
- sci-libs/netcdf
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.9-mpi.patch )
-DOCS=( README README.MPI Doc/CHANGELOG Examples/demomodule.c Examples/netcdf_demo.py )
-
-python_prepare_all() {
- use mpi && PATCHES+=( "${FILESDIR}"/${PN}-2.9.3-mpi-netcdf.patch )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use mpi; then
- cd Src/MPI || die
- ${PYTHON} compile.py || die
- mv -f mpipython mpipython-${EPYTHON} || die
- fi
-}
-
-python_test() {
- cd "${S}"/Tests || die
- python_foreach_impl nosetests
-}
-
-python_install() {
- distutils-r1_python_install
-
- if use mpi; then
- cd Src/MPI || die
- python_newexe mpipython-${EPYTHON} mpipython
- fi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( Doc/Reference/. )
- use mpi && EXAMPLES=( Examples/mpi.py )
- distutils-r1_python_install_all
-}