summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch11
-rw-r--r--net-misc/mosh/mosh-1.3.2-r2.ebuild (renamed from net-misc/mosh/mosh-1.3.2-r1.ebuild)1
2 files changed, 12 insertions, 0 deletions
diff --git a/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch b/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch
new file mode 100644
index 000000000000..0203cfff6b23
--- /dev/null
+++ b/net-misc/mosh/files/mosh-1.3.2-bind-misinterpret.patch
@@ -0,0 +1,11 @@
+--- a/src/network/network.cc
++++ b/src/network/network.cc
+@@ -335,7 +335,7 @@ bool Connection::try_bind( const char *addr, int port_low, int port_high )
+ }
+ }
+
+- if ( bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
++ if ( ::bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
+ set_MTU( local_addr.sa.sa_family );
+ return true;
+ } else if ( i == search_high ) { /* last port to search */
diff --git a/net-misc/mosh/mosh-1.3.2-r1.ebuild b/net-misc/mosh/mosh-1.3.2-r2.ebuild
index 469c7b1f214b..710a8c1fe272 100644
--- a/net-misc/mosh/mosh-1.3.2-r1.ebuild
+++ b/net-misc/mosh/mosh-1.3.2-r2.ebuild
@@ -37,6 +37,7 @@ DEPEND="${RDEPEND}
# [0] - avoid sandbox-violation calling git describe in Makefile.
PATCHES=(
"${FILESDIR}"/${PN}-1.2.5-git-version.patch
+ "${FILESDIR}"/${P}-bind-misinterpret.patch
)
src_prepare() {