summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/funzix/files/funzix-1.0-fix-build-system.patch8
-rw-r--r--app-arch/funzix/funzix-1.0.ebuild14
2 files changed, 17 insertions, 5 deletions
diff --git a/app-arch/funzix/files/funzix-1.0-fix-build-system.patch b/app-arch/funzix/files/funzix-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..1fd5482d4dcd
--- /dev/null
+++ b/app-arch/funzix/files/funzix-1.0-fix-build-system.patch
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -Wall -g
++CFLAGS += -Wall
+ LDLIBS += -lz
+
+ all: funzix
diff --git a/app-arch/funzix/funzix-1.0.ebuild b/app-arch/funzix/funzix-1.0.ebuild
index 9d479a6c8eff..8f62fd7801f6 100644
--- a/app-arch/funzix/funzix-1.0.ebuild
+++ b/app-arch/funzix/funzix-1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="unpacker for the bogus ZIX format"
@@ -12,11 +14,13 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin funzix || die
- dodoc README
+ dobin funzix
+ einstalldocs
}