summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/tree/Manifest1
-rw-r--r--app-text/tree/tree-2.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
index 229d01ebf26b..999c2c79d824 100644
--- a/app-text/tree/Manifest
+++ b/app-text/tree/Manifest
@@ -1 +1,2 @@
DIST unix-tree-2.1.1.tar.bz2 52550 BLAKE2B 0f20009a6c64b07a0742637bf32366b038f5c9bb025755a0aa45edb8c92741dfbff1486179caeeb73cfa8f10de3ed8678b948c7416ee0463e785cf153e808ff0 SHA512 ed34b1d0df049986295e7f5539491acd6134fbe69050ac2634037d700a878b4937700bed777ef0624e2bb0fc8c2815bb5139272ffe575ecc9362b84e0fafc9c2
+DIST unix-tree-2.2.0.tar.bz2 56098 BLAKE2B 0df9b06265a6c6840942480360f5083836064b162591be2e779fe4f487d73bbc95105611e5d97f6670ad6f240d250f9414a25726b4adc008de7ad74eb7fb851b SHA512 642648e47d96c5f2a4f6e880a9c317c933afc95952cb54b4c1ca67bab04b6d2f2814307df9796cc28903c4a377831271033d44e273028c9dfa02007c3961a1a6
diff --git a/app-text/tree/tree-2.2.0.ebuild b/app-text/tree/tree-2.2.0.ebuild
new file mode 100644
index 000000000000..8451309c0c5a
--- /dev/null
+++ b/app-text/tree/tree-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
+SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
+S="${WORKDIR}/unix-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+}