summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/phply/Manifest1
-rw-r--r--dev-python/phply/metadata.xml12
-rw-r--r--dev-python/phply/phply-1.2.5.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/phply/Manifest b/dev-python/phply/Manifest
new file mode 100644
index 000000000000..d0382784c415
--- /dev/null
+++ b/dev-python/phply/Manifest
@@ -0,0 +1 @@
+DIST phply-1.2.5.gh.tar.gz 35624 BLAKE2B 99fe9704cef570ad3055fa6c5aaaaed866d3c41c1479efbd29bb3224ae666d2ba13ccca61e6d67a8a0da4542dec79b5fdd201254e1ad638de81fa762049f4d13 SHA512 f0e4d0a6d2dfad5163fb68660602482b6de58c0dbd60d8db2f1df0622a9da3cc24e5fd309299a4a9ccf7abde081644a9a91fac8a2800520859199060f4080dc4
diff --git a/dev-python/phply/metadata.xml b/dev-python/phply/metadata.xml
new file mode 100644
index 000000000000..5b25b95df30c
--- /dev/null
+++ b/dev-python/phply/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">phply</remote-id>
+ <remote-id type="github">viraptor/phply</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/phply/phply-1.2.5.ebuild b/dev-python/phply/phply-1.2.5.ebuild
new file mode 100644
index 000000000000..eddb961c4385
--- /dev/null
+++ b/dev-python/phply/phply-1.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lexer and parser for PHP source implemented using PLY"
+HOMEPAGE="
+ https://github.com/viraptor/phply/
+ https://pypi.org/project/phply/"
+SRC_URI="
+ https://github.com/viraptor/phply/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # namespace? seriously?
+ sed -i -e '/namespace_packages/d' setup.py || die
+ # prevent installing tests, turn phply back into normal package
+ mv tests/__init__.py phply/ || die
+ distutils-r1_src_prepare
+}