summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/qmail.eclass22
-rw-r--r--mail-mta/netqmail/netqmail-1.06-r14.ebuild4
-rw-r--r--mail-mta/notqmail/notqmail-1.08-r3.ebuild4
-rw-r--r--mail-mta/notqmail/notqmail-9999.ebuild4
4 files changed, 0 insertions, 34 deletions
diff --git a/eclass/qmail.eclass b/eclass/qmail.eclass
index c95072650f19..33157b7e7871 100644
--- a/eclass/qmail.eclass
+++ b/eclass/qmail.eclass
@@ -367,28 +367,6 @@ qmail_rootmail_fixup() {
chown -R alias:qmail "${ROOT}${QMAIL_HOME}"/alias/.maildir 2>/dev/null
}
-qmail_tcprules_fixup() {
- mkdir -p "${TCPRULES_DIR}"
- local POP_FILES=
- use pop3 && POP_FILES="pop3 pop3.cdb"
- for f in {smtp,qmtp,qmqp}{,.cdb} ${POP_FILES}; do
- old="/etc/tcp.${f}"
- new="${TCPRULES_DIR}/tcp.qmail-${f}"
- fail=0
- if [[ -f "${old}" && ! -f "${new}" ]]; then
- einfo "Moving ${old} to ${new}"
- cp "${old}" "${new}" || fail=1
- else
- fail=1
- fi
- if [[ "${fail}" = 1 && -f "${old}" ]]; then
- eerror "Error moving ${old} to ${new}, be sure to check the"
- eerror "configuration! You may have already moved the files,"
- eerror "in which case you can delete ${old}"
- fi
- done
-}
-
qmail_tcprules_build() {
for f in tcp.qmail-{smtp,qmtp,qmqp,pop3,pop3s}; do
# please note that we don't check if it exists
diff --git a/mail-mta/netqmail/netqmail-1.06-r14.ebuild b/mail-mta/netqmail/netqmail-1.06-r14.ebuild
index aef1ed5b4dd2..e1f204048728 100644
--- a/mail-mta/netqmail/netqmail-1.06-r14.ebuild
+++ b/mail-mta/netqmail/netqmail-1.06-r14.ebuild
@@ -173,10 +173,6 @@ pkg_postinst() {
elog
}
-pkg_preinst() {
- qmail_tcprules_fixup
-}
-
pkg_config() {
# avoid some weird locale problems
export LC_ALL=C
diff --git a/mail-mta/notqmail/notqmail-1.08-r3.ebuild b/mail-mta/notqmail/notqmail-1.08-r3.ebuild
index 382f241e719e..6afc55ac3bde 100644
--- a/mail-mta/notqmail/notqmail-1.08-r3.ebuild
+++ b/mail-mta/notqmail/notqmail-1.08-r3.ebuild
@@ -173,10 +173,6 @@ pkg_postinst() {
elog
}
-pkg_preinst() {
- qmail_tcprules_fixup
-}
-
pkg_config() {
# avoid some weird locale problems
export LC_ALL=C
diff --git a/mail-mta/notqmail/notqmail-9999.ebuild b/mail-mta/notqmail/notqmail-9999.ebuild
index 8673f74908f8..224aaed06285 100644
--- a/mail-mta/notqmail/notqmail-9999.ebuild
+++ b/mail-mta/notqmail/notqmail-9999.ebuild
@@ -168,10 +168,6 @@ pkg_postinst() {
elog
}
-pkg_preinst() {
- qmail_tcprules_fixup
-}
-
pkg_config() {
# avoid some weird locale problems
export LC_ALL=C