summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pid/Manifest1
-rw-r--r--dev-python/pid/pid-2.1.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pid/Manifest b/dev-python/pid/Manifest
index d0cf9b9b1bd1..592e1a20d7ab 100644
--- a/dev-python/pid/Manifest
+++ b/dev-python/pid/Manifest
@@ -1 +1,2 @@
DIST pid-2.0.1.tar.gz 9373 SHA256 054cde9c64b8ac979ec27f714e71ebb97ecf8388ea5fe29f6b93db222e92d433 SHA512 10dcded5b52c415a2fa653afdd85e5fbb06433149eee63f306ff84f225086492048db0341bf3a6e448d0654ba4c02afdb72343c0b111bc9682f2248cc4c3817a WHIRLPOOL 801386fcb80d5a7b16793cc5fd9eb6622aa303d7f8be5142f3fd10dc0453ab573b227e06a9b35dc8f3048b5019017db395c40b8c5fce65b086354cfde4853024
+DIST pid-2.1.1.tar.gz 9591 SHA256 b443169d3dc21397695b4a82016fadb4cfdb0ed8b2ddb4aaa428e1701bb34e1f SHA512 5f20338ca902d68a0c4a614b0b8229cd498712bf1750b68fa49037e9e6915c66ad562564d70d7c9308538f4302e90473a5d253dd6366bfa561f6a2248b21a45e WHIRLPOOL 52d3a196fccab813671b71c3f9d719bc741412b9cd76828902513dcf6b8fb2c4f3c0159e1fd43cbda3d39e436247248862ba5a168b710848aa6ce7b8fc26abd7
diff --git a/dev-python/pid/pid-2.1.1.ebuild b/dev-python/pid/pid-2.1.1.ebuild
new file mode 100644
index 000000000000..3db31ae19aee
--- /dev/null
+++ b/dev-python/pid/pid-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.python.org/pypi/pid https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}