summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/memwatch/memwatch-0.3.3.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.3.ebuild b/sys-process/memwatch/memwatch-0.3.3.ebuild
index 7d7b69239750..a94e93925a99 100644
--- a/sys-process/memwatch/memwatch-0.3.3.ebuild
+++ b/sys-process/memwatch/memwatch-0.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,14 +19,10 @@ RDEPEND="${DEPEND}"
CMAKE_REMOVE_MODULES_LIST="FindCurses"
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
+src_prepare() {
+ sed -e "s/^set(CMAKE_C_FLAGS.*/set(CMAKE_C_FLAGS \"${CFLAGS}\")/" \
+ -e "1s/^/project(${PN})\n/" \
+ -i CMakeLists.txt || die "can't patch CMakeLists.txt"
-src_install() {
- cmake-utils_src_install
+ cmake-utils_src_prepare
}