summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/bpftool/bpftool-7.4.0.ebuild6
-rw-r--r--dev-util/bpftool/bpftool-9999.ebuild6
2 files changed, 4 insertions, 8 deletions
diff --git a/dev-util/bpftool/bpftool-7.4.0.ebuild b/dev-util/bpftool/bpftool-7.4.0.ebuild
index 55a5c88923ff..b1481b3e2cbe 100644
--- a/dev-util/bpftool/bpftool-7.4.0.ebuild
+++ b/dev-util/bpftool/bpftool-7.4.0.ebuild
@@ -59,6 +59,7 @@ BDEPEND="
${PYTHON_DEPS}
app-arch/tar
dev-python/docutils
+ $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}[llvm_targets_BPF]')
"
CONFIG_CHECK="~DEBUG_INFO_BTF"
@@ -106,6 +107,7 @@ bpftool_make() {
emake \
ARCH="$(tc-arch-kernel)" \
+ CLANG="$(get_llvm_prefix -b)/bin/clang" \
HOSTAR="$(tc-getBUILD_AR)" \
HOSTCC="$(tc-getBUILD_CC)" \
HOSTLD="$(tc-getBUILD_LD)" \
@@ -126,7 +128,3 @@ src_install() {
bpftool_make DESTDIR="${D}" -C src install
bpftool_make mandir="${ED}"/usr/share/man -C docs install
}
-
-pkg_postinst() {
- optfeature "clang-bpf-co-re support" sys-devel/clang[llvm_targets_BPF]
-}
diff --git a/dev-util/bpftool/bpftool-9999.ebuild b/dev-util/bpftool/bpftool-9999.ebuild
index 03f97becf881..4c6ef01a02a4 100644
--- a/dev-util/bpftool/bpftool-9999.ebuild
+++ b/dev-util/bpftool/bpftool-9999.ebuild
@@ -59,6 +59,7 @@ BDEPEND="
${PYTHON_DEPS}
app-arch/tar
dev-python/docutils
+ $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}[llvm_targets_BPF]')
"
CONFIG_CHECK="~DEBUG_INFO_BTF"
@@ -95,6 +96,7 @@ bpftool_make() {
emake \
ARCH="$(tc-arch-kernel)" \
+ CLANG="$(get_llvm_prefix -b)/bin/clang" \
HOSTAR="$(tc-getBUILD_AR)" \
HOSTCC="$(tc-getBUILD_CC)" \
HOSTLD="$(tc-getBUILD_LD)" \
@@ -115,7 +117,3 @@ src_install() {
bpftool_make DESTDIR="${D}" -C src install
bpftool_make mandir="${ED}"/usr/share/man -C docs install
}
-
-pkg_postinst() {
- optfeature "clang-bpf-co-re support" sys-devel/clang[llvm_targets_BPF]
-}