summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/lrcalc/Manifest1
-rw-r--r--dev-python/lrcalc/lrcalc-2.1.ebuild31
-rw-r--r--dev-python/lrcalc/metadata.xml27
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/lrcalc/Manifest b/dev-python/lrcalc/Manifest
new file mode 100644
index 000000000000..087604119042
--- /dev/null
+++ b/dev-python/lrcalc/Manifest
@@ -0,0 +1 @@
+DIST lrcalc_python-2.1.tar.gz 16452 BLAKE2B 9abdb23834e136f10d960695751bc6569f248abf72a7e89f7feafe4ce046bea47faed299e4ecf5e99ab419e6cb02bb861736006c20de2e328321b9bacb96845d SHA512 b6d3bc61be1fe478bef74d1c51d7072521ef8d43bf64323cce0985582e2981c02382fa38a2501f5c9537349573721a1de8e166149ee4df31ed13bf0f0fb5d2a8
diff --git a/dev-python/lrcalc/lrcalc-2.1.ebuild b/dev-python/lrcalc/lrcalc-2.1.ebuild
new file mode 100644
index 000000000000..35638f532ac4
--- /dev/null
+++ b/dev-python/lrcalc/lrcalc-2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for sci-mathematics/lrcalc"
+HOMEPAGE="https://bitbucket.org/asbuch/lrcalc"
+# Avoid a name clash with the sci-mathematics/lrcalc tarball
+SRC_URI="$(pypi_sdist_url) -> ${PN}_python-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="~sci-mathematics/lrcalc-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix this typo in setup.py to avoid a QA warning
+ sed -i setup.py \
+ -e 's/long_description_type/long_description_content_type/' \
+ || die
+ default
+}
diff --git a/dev-python/lrcalc/metadata.xml b/dev-python/lrcalc/metadata.xml
new file mode 100644
index 000000000000..8e0632fe2c3d
--- /dev/null
+++ b/dev-python/lrcalc/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="bitbucket">asbuch/lrcalc</remote-id>
+ <remote-id type="pypi">lrcalc</remote-id>
+ </upstream>
+</pkgmetadata>