summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/docker-bench-security/docker-bench-security-1.3.2.ebuild2
-rw-r--r--app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild2
-rw-r--r--app-containers/docker-cli/docker-cli-20.10.12.ebuild2
-rw-r--r--app-containers/docker-cli/docker-cli-20.10.9.ebuild2
-rw-r--r--app-containers/docker-gc/docker-gc-9999.ebuild2
-rw-r--r--app-containers/docker/Manifest (renamed from app-emulation/docker/Manifest)0
-rw-r--r--app-containers/docker/docker-20.10.12-r1.ebuild (renamed from app-emulation/docker/docker-20.10.12-r1.ebuild)4
-rw-r--r--app-containers/docker/docker-20.10.9.ebuild (renamed from app-emulation/docker/docker-20.10.9.ebuild)4
-rw-r--r--app-containers/docker/files/etcd-F_OFD_GETLK-fix.patch (renamed from app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch)0
-rw-r--r--app-containers/docker/files/ppc64-buildmode.patch (renamed from app-emulation/docker/files/ppc64-buildmode.patch)0
-rw-r--r--app-containers/docker/metadata.xml (renamed from app-emulation/docker/metadata.xml)0
-rw-r--r--app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild2
-rw-r--r--app-containers/runc/runc-1.0.2-r1.ebuild2
-rw-r--r--app-containers/runc/runc-1.0.3.ebuild2
-rw-r--r--app-emulation/vagrant/vagrant-2.2.18-r1.ebuild2
-rw-r--r--dev-util/ebuildtester/ebuildtester-0.1.27.ebuild2
-rw-r--r--dev-util/ebuildtester/ebuildtester-0.1.29.ebuild2
-rw-r--r--dev-util/ebuildtester/ebuildtester-0.1.30.ebuild2
-rw-r--r--net-misc/gns3-server/gns3-server-2.2.25.ebuild2
-rw-r--r--net-misc/gns3-server/gns3-server-2.2.26.ebuild2
-rw-r--r--profiles/arch/powerpc/ppc64/64le/package.mask2
-rw-r--r--profiles/arch/powerpc/ppc64/package.mask2
-rw-r--r--profiles/updates/4Q-20211
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.24.ebuild2
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.25.ebuild2
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild2
-rw-r--r--x11-plugins/docker/docker-1.5-r2.ebuild2
27 files changed, 25 insertions, 24 deletions
diff --git a/app-containers/docker-bench-security/docker-bench-security-1.3.2.ebuild b/app-containers/docker-bench-security/docker-bench-security-1.3.2.ebuild
index 6e423e8ccc19..7f98da207205 100644
--- a/app-containers/docker-bench-security/docker-bench-security-1.3.2.ebuild
+++ b/app-containers/docker-bench-security/docker-bench-security-1.3.2.ebuild
@@ -11,7 +11,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND=">=app-emulation/docker-1.10"
+RDEPEND=">=app-containers/docker-1.10"
src_install() {
dobin "${FILESDIR}/docker-bench-security"
diff --git a/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild b/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
index 6e423e8ccc19..7f98da207205 100644
--- a/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
+++ b/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
@@ -11,7 +11,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND=">=app-emulation/docker-1.10"
+RDEPEND=">=app-containers/docker-1.10"
src_install() {
dobin "${FILESDIR}/docker-bench-security"
diff --git a/app-containers/docker-cli/docker-cli-20.10.12.ebuild b/app-containers/docker-cli/docker-cli-20.10.12.ebuild
index 8f6f4fd8fa5c..bfb69f3a3022 100644
--- a/app-containers/docker-cli/docker-cli-20.10.12.ebuild
+++ b/app-containers/docker-cli/docker-cli-20.10.12.ebuild
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
IUSE="hardened"
-RDEPEND="!<app-emulation/docker-20.10.1"
+RDEPEND="!<app-containers/docker-20.10.1"
BDEPEND="
>=dev-lang/go-1.16.6
dev-go/go-md2man"
diff --git a/app-containers/docker-cli/docker-cli-20.10.9.ebuild b/app-containers/docker-cli/docker-cli-20.10.9.ebuild
index 30e81b53f7fc..271f9e895a6d 100644
--- a/app-containers/docker-cli/docker-cli-20.10.9.ebuild
+++ b/app-containers/docker-cli/docker-cli-20.10.9.ebuild
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv ~x86"
IUSE="hardened"
-RDEPEND="!<app-emulation/docker-20.10.1"
+RDEPEND="!<app-containers/docker-20.10.1"
BDEPEND="
>=dev-lang/go-1.16.6
dev-go/go-md2man"
diff --git a/app-containers/docker-gc/docker-gc-9999.ebuild b/app-containers/docker-gc/docker-gc-9999.ebuild
index 9324081bc947..4be76d94296a 100644
--- a/app-containers/docker-gc/docker-gc-9999.ebuild
+++ b/app-containers/docker-gc/docker-gc-9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://github.com/spotify/docker-gc/"
LICENSE="Apache-2.0"
SLOT="0"
-RDEPEND="app-emulation/docker"
+RDEPEND="app-containers/docker"
src_install() {
dosbin docker-gc
diff --git a/app-emulation/docker/Manifest b/app-containers/docker/Manifest
index 38d76034e258..38d76034e258 100644
--- a/app-emulation/docker/Manifest
+++ b/app-containers/docker/Manifest
diff --git a/app-emulation/docker/docker-20.10.12-r1.ebuild b/app-containers/docker/docker-20.10.12-r1.ebuild
index 0e74f25a901b..cc2c20dd742b 100644
--- a/app-emulation/docker/docker-20.10.12-r1.ebuild
+++ b/app-containers/docker/docker-20.10.12-r1.ebuild
@@ -260,7 +260,7 @@ pkg_postinst() {
ewarn "Starting with docker 20.10.2, docker has been split into"
ewarn "two packages upstream, so Gentoo has followed suit."
ewarn
- ewarn "app-emulation/docker contains the daemon and"
+ ewarn "app-containers/docker contains the daemon and"
ewarn "app-containers/docker-cli contains the docker command."
ewarn
ewarn "docker currently installs docker-cli using the cli use flag."
@@ -268,7 +268,7 @@ pkg_postinst() {
ewarn "This use flag is temporary, so you need to take the"
ewarn "following actions:"
ewarn
- ewarn "First, disable the cli use flag for app-emulation/docker"
+ ewarn "First, disable the cli use flag for app-containers/docker"
ewarn
ewarn "Then, if you need docker-cli and docker on the same machine,"
ewarn "run the following command:"
diff --git a/app-emulation/docker/docker-20.10.9.ebuild b/app-containers/docker/docker-20.10.9.ebuild
index 4f148cbcce27..553c7e547a7d 100644
--- a/app-emulation/docker/docker-20.10.9.ebuild
+++ b/app-containers/docker/docker-20.10.9.ebuild
@@ -260,7 +260,7 @@ pkg_postinst() {
ewarn "Starting with docker 20.10.2, docker has been split into"
ewarn "two packages upstream, so Gentoo has followed suit."
ewarn
- ewarn "app-emulation/docker contains the daemon and"
+ ewarn "app-containers/docker contains the daemon and"
ewarn "app-containers/docker-cli contains the docker command."
ewarn
ewarn "docker currently installs docker-cli using the cli use flag."
@@ -268,7 +268,7 @@ pkg_postinst() {
ewarn "This use flag is temporary, so you need to take the"
ewarn "following actions:"
ewarn
- ewarn "First, disable the cli use flag for app-emulation/docker"
+ ewarn "First, disable the cli use flag for app-containers/docker"
ewarn
ewarn "Then, if you need docker-cli and docker on the same machine,"
ewarn "run the following command:"
diff --git a/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch b/app-containers/docker/files/etcd-F_OFD_GETLK-fix.patch
index bd574e26f040..bd574e26f040 100644
--- a/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
+++ b/app-containers/docker/files/etcd-F_OFD_GETLK-fix.patch
diff --git a/app-emulation/docker/files/ppc64-buildmode.patch b/app-containers/docker/files/ppc64-buildmode.patch
index f16756e85041..f16756e85041 100644
--- a/app-emulation/docker/files/ppc64-buildmode.patch
+++ b/app-containers/docker/files/ppc64-buildmode.patch
diff --git a/app-emulation/docker/metadata.xml b/app-containers/docker/metadata.xml
index e58aa2015b46..e58aa2015b46 100644
--- a/app-emulation/docker/metadata.xml
+++ b/app-containers/docker/metadata.xml
diff --git a/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild b/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
index 9704fffb853f..bbc7926f7164 100644
--- a/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
+++ b/app-containers/go-secbench/go-secbench-0.1.0-r1.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="~amd64"
RESTRICT="test"
DEPEND="dev-lang/go"
-RDEPEND="app-emulation/docker"
+RDEPEND="app-containers/docker"
src_compile() {
GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
diff --git a/app-containers/runc/runc-1.0.2-r1.ebuild b/app-containers/runc/runc-1.0.2-r1.ebuild
index 38b6da62493d..d31a90d65a0d 100644
--- a/app-containers/runc/runc-1.0.2-r1.ebuild
+++ b/app-containers/runc/runc-1.0.2-r1.ebuild
@@ -43,7 +43,7 @@ RESTRICT+=" test"
S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
+ # Taken from app-containers/docker-1.7.0-r1
export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
-L${ESYSROOT}/usr/$(get_libdir)"
diff --git a/app-containers/runc/runc-1.0.3.ebuild b/app-containers/runc/runc-1.0.3.ebuild
index db1d0c6af602..b4281cd2aad2 100644
--- a/app-containers/runc/runc-1.0.3.ebuild
+++ b/app-containers/runc/runc-1.0.3.ebuild
@@ -41,7 +41,7 @@ RESTRICT+=" test"
S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
+ # Taken from app-containers/docker-1.7.0-r1
export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
-L${ESYSROOT}/usr/$(get_libdir)"
diff --git a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
index 2b6991ee84d0..3d8077b15ec7 100644
--- a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
@@ -91,5 +91,5 @@ all_ruby_install() {
optfeature_header "Optional emulation/container backends:"
optfeature "VirtualBox support" app-emulation/virtualbox
- optfeature "Docker support" app-emulation/docker
+ optfeature "Docker support" app-containers/docker
}
diff --git a/dev-util/ebuildtester/ebuildtester-0.1.27.ebuild b/dev-util/ebuildtester/ebuildtester-0.1.27.ebuild
index b6204349693b..3d2c48643117 100644
--- a/dev-util/ebuildtester/ebuildtester-0.1.27.ebuild
+++ b/dev-util/ebuildtester/ebuildtester-0.1.27.ebuild
@@ -18,7 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- app-emulation/docker
+ app-containers/docker
sys-fs/fuse
"
diff --git a/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild b/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
index b6204349693b..3d2c48643117 100644
--- a/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
+++ b/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
@@ -18,7 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- app-emulation/docker
+ app-containers/docker
sys-fs/fuse
"
diff --git a/dev-util/ebuildtester/ebuildtester-0.1.30.ebuild b/dev-util/ebuildtester/ebuildtester-0.1.30.ebuild
index b6204349693b..3d2c48643117 100644
--- a/dev-util/ebuildtester/ebuildtester-0.1.30.ebuild
+++ b/dev-util/ebuildtester/ebuildtester-0.1.30.ebuild
@@ -18,7 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- app-emulation/docker
+ app-containers/docker
sys-fs/fuse
"
diff --git a/net-misc/gns3-server/gns3-server-2.2.25.ebuild b/net-misc/gns3-server/gns3-server-2.2.25.ebuild
index 9d91356deda2..2b820f4601e9 100644
--- a/net-misc/gns3-server/gns3-server-2.2.25.ebuild
+++ b/net-misc/gns3-server/gns3-server-2.2.25.ebuild
@@ -63,7 +63,7 @@ pkg_postinst() {
elog ""
optfeature "QEMU Support" "app-emulation/qemu"
optfeature "Virtualbox Support" "app-emulation/virtualbox"
- optfeature "Docker Support" "app-emulation/docker"
+ optfeature "Docker Support" "app-containers/docker"
optfeature "Wireshark Support" "net-analyzer/wireshark"
elog ""
elog "The following packages are currently unsupported:"
diff --git a/net-misc/gns3-server/gns3-server-2.2.26.ebuild b/net-misc/gns3-server/gns3-server-2.2.26.ebuild
index 9d91356deda2..2b820f4601e9 100644
--- a/net-misc/gns3-server/gns3-server-2.2.26.ebuild
+++ b/net-misc/gns3-server/gns3-server-2.2.26.ebuild
@@ -63,7 +63,7 @@ pkg_postinst() {
elog ""
optfeature "QEMU Support" "app-emulation/qemu"
optfeature "Virtualbox Support" "app-emulation/virtualbox"
- optfeature "Docker Support" "app-emulation/docker"
+ optfeature "Docker Support" "app-containers/docker"
optfeature "Wireshark Support" "net-analyzer/wireshark"
elog ""
elog "The following packages are currently unsupported:"
diff --git a/profiles/arch/powerpc/ppc64/64le/package.mask b/profiles/arch/powerpc/ppc64/64le/package.mask
index 5a33b5659e8f..a691c07c55ec 100644
--- a/profiles/arch/powerpc/ppc64/64le/package.mask
+++ b/profiles/arch/powerpc/ppc64/64le/package.mask
@@ -31,7 +31,7 @@ sci-mathematics/geogebra-bin
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-10-17)
# works on ppc64le
--app-emulation/docker
+-app-containers/docker
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-09-22
# criu works on ppc64le
diff --git a/profiles/arch/powerpc/ppc64/package.mask b/profiles/arch/powerpc/ppc64/package.mask
index 7b32acd5c13c..52066e1297a4 100644
--- a/profiles/arch/powerpc/ppc64/package.mask
+++ b/profiles/arch/powerpc/ppc64/package.mask
@@ -32,7 +32,7 @@ sci-mathematics/geogebra-bin
# Fails to build with buildmode=pie assumptions, which
# does not work on big-endian ppc64
# next releases remove that assumption and mask will be lifted
-app-emulation/docker
+app-containers/docker
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-09-18)
# openjfx:11 does not work on ppc64be
diff --git a/profiles/updates/4Q-2021 b/profiles/updates/4Q-2021
index db382d81f45b..c1460e49ad43 100644
--- a/profiles/updates/4Q-2021
+++ b/profiles/updates/4Q-2021
@@ -60,3 +60,4 @@ move app-emulation/s6-overlay app-containers/s6-overlay
move app-emulation/snapd app-containers/snapd
move app-emulation/umoci app-containers/umoci
move app-emulation/docker-cli app-containers/docker-cli
+move app-emulation/docker app-containers/docker
diff --git a/sys-cluster/charliecloud/charliecloud-0.24.ebuild b/sys-cluster/charliecloud/charliecloud-0.24.ebuild
index 62f2e98e4520..ad6833306501 100644
--- a/sys-cluster/charliecloud/charliecloud-0.24.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.24.ebuild
@@ -73,7 +73,7 @@ src_configure() {
pkg_postinst() {
elog "Various builders are supported, as alternative to the internal ch-image."
optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-emulation/docker
+ optfeature "Building with Docker" app-containers/docker
optfeature "Progress bars during long operations" sys-apps/pv
optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
optfeature "Mount and umount squashfs images" sys-fs/squashfuse
diff --git a/sys-cluster/charliecloud/charliecloud-0.25.ebuild b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
index b551d449417f..1d092db33c89 100644
--- a/sys-cluster/charliecloud/charliecloud-0.25.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
@@ -71,7 +71,7 @@ src_configure() {
pkg_postinst() {
elog "Various builders are supported, as alternative to the internal ch-image."
optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-emulation/docker
+ optfeature "Building with Docker" app-containers/docker
optfeature "Progress bars during long operations" sys-apps/pv
optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
optfeature "Mount and umount squashfs images" sys-fs/squashfuse
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index b551d449417f..1d092db33c89 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -71,7 +71,7 @@ src_configure() {
pkg_postinst() {
elog "Various builders are supported, as alternative to the internal ch-image."
optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-emulation/docker
+ optfeature "Building with Docker" app-containers/docker
optfeature "Progress bars during long operations" sys-apps/pv
optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
optfeature "Mount and umount squashfs images" sys-fs/squashfuse
diff --git a/x11-plugins/docker/docker-1.5-r2.ebuild b/x11-plugins/docker/docker-1.5-r2.ebuild
index 9f742ebe552d..4871b7a4c813 100644
--- a/x11-plugins/docker/docker-1.5-r2.ebuild
+++ b/x11-plugins/docker/docker-1.5-r2.ebuild
@@ -28,5 +28,5 @@ src_compile() {
}
pkg_postinst() {
- einfo "To avoid collision with app-emulation/docker, binary was renamed to wmdocker"
+ einfo "To avoid collision with app-containers/docker, binary was renamed to wmdocker"
}