summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/conky/conky-1.10.6-r2.ebuild5
-rw-r--r--app-admin/conky/files/conky-1.10.6-gcc-7.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/app-admin/conky/conky-1.10.6-r2.ebuild b/app-admin/conky/conky-1.10.6-r2.ebuild
index 12ba1da0f256..39079b09ae68 100644
--- a/app-admin/conky/conky-1.10.6-r2.ebuild
+++ b/app-admin/conky/conky-1.10.6-r2.ebuild
@@ -73,7 +73,10 @@ CONFIG_CHECK=~IPV6
DOCS=( README.md TODO ChangeLog NEWS AUTHORS )
-PATCHES=( "${FILESDIR}"/${P}-new_graph-oor.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-new_graph-oor.patch
+ "${FILESDIR}"/${P}-gcc-7.patch
+ )
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="You can find sample configurations at ${ROOT%/}/usr/share/doc/${PF}.
diff --git a/app-admin/conky/files/conky-1.10.6-gcc-7.patch b/app-admin/conky/files/conky-1.10.6-gcc-7.patch
new file mode 100644
index 000000000000..6784129d39c4
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.6-gcc-7.patch
@@ -0,0 +1,11 @@
+diff -Naur a/src/luamm.hh b/src/luamm.hh
+--- a/src/luamm.hh 2017-07-07 15:05:28.250032963 +0200
++++ b/src/luamm.hh 2017-07-07 15:05:43.230033134 +0200
+@@ -28,6 +28,7 @@
+ #include <exception>
+ #include <stdexcept>
+ #include <string>
++#include <functional>
+
+ #include <lua.hpp>
+