summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.27.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 6b1d28e702de..e6b9db8bd3ce 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.35.19.gh.tar.gz 13376459 BLAKE2B ba64ff0dc221782ce23592a6d6a146a
DIST botocore-1.35.24.gh.tar.gz 13406391 BLAKE2B ddc1c456e4358b3e28ca8f6a92230fb843309fd6059eaf909a9fb3de0bd580fb52389173187e0794054b9f1bc21a829f457b80067868c13fd7987fc682acd024 SHA512 7a1e8c1a85e8699a811a41b59cdefcee2457c5dfdf01d54f3048f894869c5c4033287909095bf15304e408c268cf772194655afffff280dbb6fd6c6daac1d8cb
DIST botocore-1.35.25.gh.tar.gz 13409661 BLAKE2B 49f846dfd62033b320a7b5e1afeae6c18cb94768b9b8dda1b9b373dac35ed846f8958ab5efd183c70f297de1dfb6ed0447503cab6f9b380cd31b8445c760bfd9 SHA512 d6a2ad3db3dda7597d351a1f216feb3453b708055b956a2e4eacd24035298dffe54d906edfe5da3fdb674a9bb44a5ca4096022f3d0a312b1a12b29eea5ea48da
DIST botocore-1.35.26.gh.tar.gz 13410309 BLAKE2B da2111d9f6af1795ab1c50332089109b4627a64a7904080f8586bfc5c5c5228896caff703131d864bfde8dd3b8ec2d39eaac2cdc03b4d38febded9ac56b0eaab SHA512 6364e9af0b619961eb2984e34619617a75706c468538c91d375ed5172e85b39a2583e79278cce23fdbc08f68162fe83b4ec7f30d68f18ebf82eea8610d1243f9
+DIST botocore-1.35.27.gh.tar.gz 13402723 BLAKE2B e9c21aeff1470a7fdcf02f51b68f6d36c7186effdab2617cd91813d7db013de0131e7b17423f82c7a8bcdc2c8981695c4de3869bad93af2882a74dddfd4c96d0 SHA512 2b8fdba377bdb54ebd6f2a5ce48f38a4c20c8e77b1dff40271fa3d16b6eb69025edc7a7c8cdc4f0b9ab1c0fc584a14db18f366c096cbff11f7348978bb8a9574
diff --git a/dev-python/botocore/botocore-1.35.27.ebuild b/dev-python/botocore/botocore-1.35.27.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.27.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}