summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/needrestart/Manifest1
-rw-r--r--app-admin/needrestart/needrestart-3.7.ebuild41
-rw-r--r--app-admin/needrestart/needrestart-9999.ebuild5
3 files changed, 44 insertions, 3 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
index 3b9b3e406169..87172582e6c2 100644
--- a/app-admin/needrestart/Manifest
+++ b/app-admin/needrestart/Manifest
@@ -1 +1,2 @@
DIST needrestart-3.6.tar.gz 71159 BLAKE2B 76994ef0e77a4db0532dca2e17990097b2314f912fc3c32e67643eca7c44fff9611a42b49abd55f959a0e959d6ea69cfef36ad9008c86debfd125b64bdc673b5 SHA512 5c0f2f427c93e6f621fc1727f6abf42651e184e168b3f720708ac73b425bc7dfb94622c6cc2afad1161e3ffbfd36500eb99c375f2f5a525c9cd10d7142f1e365
+DIST needrestart-3.7.tar.gz 74515 BLAKE2B 920076d4a0bdfff1e8adbc0d158565692ba78a64d36b559ec8afe39ae93f6adea4e7ab853b44f52e8500e51f5eef562cd73cc5466de41c7deeb22452d8615e1e SHA512 bb88bf2be2e56a58ea4114f7285b64cb2897cd5d187551018fc3126d9560e150e5938693a824d54a39cc9185c55c9dc5cddece71b24b7ee99a092ad829a2ba49
diff --git a/app-admin/needrestart/needrestart-3.7.ebuild b/app-admin/needrestart/needrestart-3.7.ebuild
new file mode 100644
index 000000000000..883d2efdf3d0
--- /dev/null
+++ b/app-admin/needrestart/needrestart-3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/liske/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+ !systemd? ( sys-apps/init-system-helpers )
+ amd64? ( sys-apps/iucode_tool )
+ x86? ( sys-apps/iucode_tool )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}
diff --git a/app-admin/needrestart/needrestart-9999.ebuild b/app-admin/needrestart/needrestart-9999.ebuild
index d530994f324f..883d2efdf3d0 100644
--- a/app-admin/needrestart/needrestart-9999.ebuild
+++ b/app-admin/needrestart/needrestart-9999.ebuild
@@ -6,7 +6,6 @@ EAPI=8
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/liske/${PN}.git"
inherit git-r3
- SRC_URI=""
else
SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
@@ -14,9 +13,9 @@ fi
DESCRIPTION="Restart daemons after library updates"
HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
-IUSE="systemd"
-SLOT="0"
LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd"
RDEPEND="
>=sys-apps/sed-4.2.2