summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-1.patch10
-rw-r--r--sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-2.patch32
-rw-r--r--sci-geosciences/grass/grass-7.2.0-r1.ebuild1
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-1.patch b/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-1.patch
new file mode 100644
index 000000000000..115ff06febc3
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-1.patch
@@ -0,0 +1,10 @@
+Index: /grass/trunk/lib/raster/R.h
+===================================================================
+--- /grass/trunk/lib/raster/R.h (revision 71264)
++++ /grass/trunk/lib/raster/R.h (revision 71265)
+@@ -1,5 +1,4 @@
+ #include <grass/config.h>
+ #include <grass/gis.h>
+-#include <rpc/types.h>
+ #ifdef HAVE_GDAL
+ #include <gdal.h>
diff --git a/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-2.patch b/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-2.patch
new file mode 100644
index 000000000000..c1361f6af088
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-7.2.0-glibc-2.26-2.patch
@@ -0,0 +1,32 @@
+Index: /grass/branches/releasebranch_7_2/lib/raster/get_row.c
+===================================================================
+--- /grass/branches/releasebranch_7_2/lib/raster/get_row.c (revision 71943)
++++ /grass/branches/releasebranch_7_2/lib/raster/get_row.c (revision 71944)
+@@ -15,6 +15,4 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+-
+-#include <rpc/types.h> /* need this for sgi */
+
+ #include <grass/config.h>
+Index: /grass/branches/releasebranch_7_2/lib/raster/open.c
+===================================================================
+--- /grass/branches/releasebranch_7_2/lib/raster/open.c (revision 71943)
++++ /grass/branches/releasebranch_7_2/lib/raster/open.c (revision 71944)
+@@ -13,6 +13,4 @@
+ */
+
+-#include <rpc/types.h>
+-#include <rpc/xdr.h>
+ #include <unistd.h>
+ #include <string.h>
+Index: /grass/branches/releasebranch_7_2/lib/raster/range.c
+===================================================================
+--- /grass/branches/releasebranch_7_2/lib/raster/range.c (revision 71943)
++++ /grass/branches/releasebranch_7_2/lib/raster/range.c (revision 71944)
+@@ -13,5 +13,4 @@
+
+ #include <unistd.h>
+-#include <rpc/types.h> /* need this for sgi */
+
+ #include <grass/raster.h>
diff --git a/sci-geosciences/grass/grass-7.2.0-r1.ebuild b/sci-geosciences/grass/grass-7.2.0-r1.ebuild
index 00657af184ed..233823e1fa49 100644
--- a/sci-geosciences/grass/grass-7.2.0-r1.ebuild
+++ b/sci-geosciences/grass/grass-7.2.0-r1.ebuild
@@ -79,6 +79,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}/${PN}"-7.0.1-declare-inespg.patch
"${FILESDIR}/${P}"-gcc7.patch
+ "${FILESDIR}/${P}"-glibc-2.26-{1,2}.patch
)
pkg_setup() {