summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unzip/unzip-6.0_p25.ebuild')
-rw-r--r--app-arch/unzip/unzip-6.0_p25.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-arch/unzip/unzip-6.0_p25.ebuild b/app-arch/unzip/unzip-6.0_p25.ebuild
index bdbcb3b4e539..dcd460f9f049 100644
--- a/app-arch/unzip/unzip-6.0_p25.ebuild
+++ b/app-arch/unzip/unzip-6.0_p25.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic
MY_PV="${PV//.}"
MY_PV="${MY_PV%_p*}"
@@ -57,14 +57,14 @@ src_prepare() {
src_configure() {
case ${CHOST} in
- i?86*-*linux*) TARGET="linux_asm" ;;
- *linux*) TARGET="linux_noasm" ;;
- i?86*-*bsd* | \
- i?86*-dragonfly*) TARGET="freebsd" ;; # mislabelled bsd with x86 asm
- *bsd* | *dragonfly*) TARGET="bsd" ;;
- *-darwin*) TARGET="macosx" ;;
- *-cygwin*) TARGET="cygwin" ;;
- *) die "Unknown target; please update the ebuild to handle ${CHOST} " ;;
+ i?86*-*linux*) TARGET="linux_asm" ;;
+ *linux*) TARGET="linux_noasm" ;;
+ i?86*-*bsd* | \
+ i?86*-dragonfly*) TARGET="freebsd" ;; # mislabelled bsd with x86 asm
+ *bsd* | *dragonfly*) TARGET="bsd" ;;
+ *-darwin*) TARGET="macosx" ;;
+ *-cygwin*) TARGET="cygwin" ;;
+ *) die "Unknown target; please update the ebuild to handle ${CHOST} " ;;
esac
[[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
@@ -75,7 +75,7 @@ src_configure() {
src_compile() {
ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" \
- emake -f unix/Makefile ${TARGET}
+ emake -f unix/Makefile ${TARGET}
}
src_install() {