summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-0.3.1.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.3.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.3.1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.3.1.ebuild
new file mode 100644
index 000000000000..0d39029f39eb
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+"