summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zoinks')
-rw-r--r--app-editors/zoinks/Manifest1
-rw-r--r--app-editors/zoinks/metadata.xml7
-rw-r--r--app-editors/zoinks/zoinks-0.4.1.ebuild46
3 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/zoinks/Manifest b/app-editors/zoinks/Manifest
new file mode 100644
index 000000000000..63478dc8c9bf
--- /dev/null
+++ b/app-editors/zoinks/Manifest
@@ -0,0 +1 @@
+DIST zoinks-0.4.1.tar.gz 322009 SHA256 bd8b229904b2e0aeae4742cc9eda882cd47874c86dcf21df8b3d77c830d301cd SHA512 f1608755b25dd0b4cd2840592b9abd2df462d9a4b97847bf813d46e9f3fca0d15e41ef80b8bafbbb494a7c446b5f727a258f44d28fdbbf2ceddc179292d15a79 WHIRLPOOL 676640d85d9136b9ed227bc1c80a2ae4ac45476eaf6617d988167b78f8c98c2b71951271174ecae5b136fa752e96c7e910d98c5d028c72f47cca18ae96d19f01
diff --git a/app-editors/zoinks/metadata.xml b/app-editors/zoinks/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-editors/zoinks/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-editors/zoinks/zoinks-0.4.1.ebuild b/app-editors/zoinks/zoinks-0.4.1.ebuild
new file mode 100644
index 000000000000..3ae66d2e70af
--- /dev/null
+++ b/app-editors/zoinks/zoinks-0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="programmer's text editor and development environment"
+HOMEPAGE="http://zoinks.mikelockwood.com"
+SRC_URI="http://${PN}.mikelockwood.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i -e 's:-g -Werror::g' configure* || die
+ tc-export CXX
+}
+
+src_configure() {
+ econf $(use_enable nls) --disable-imlib
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README
+ doicon ide/Pixmaps/${PN}.xpm
+ make_desktop_entry ${PN} "Zoinks!" ${PN} "Utility;TextEditor"
+}
+
+pkg_postinst() {
+ if ! [[ ${REPLACING_VERSIONS} ]]; then
+ elog "If you see this message when starting zoinks:"
+ elog "zoinks: TFont.cpp:40: TFont::TFont(const char*): Assertion \`fFontSet' failed."
+ elog "You need to install media-fonts/font-adobe-{75,100dpi}"
+ fi
+}