summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-python/eselect-python-20131210.ebuild')
-rw-r--r--app-eselect/eselect-python/eselect-python-20131210.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20131210.ebuild b/app-eselect/eselect-python/eselect-python-20131210.ebuild
new file mode 100644
index 000000000000..7f1fd0c92075
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20131210.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+# Avoid autotool deps for released versions for circ dep issues.
+if [[ ${PV} == "99999999" ]] ; then
+ DEPEND="sys-devel/autoconf"
+else
+ DEPEND=""
+fi
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ local ret=0
+ ebegin "Running 'eselect python update'"
+ eselect python update --python2 --if-unset || ret=1
+ eselect python update --python3 --if-unset || ret=1
+ eend ${ret}
+}