summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/physlock/physlock-11.ebuild')
-rw-r--r--app-misc/physlock/physlock-11.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/physlock/physlock-11.ebuild b/app-misc/physlock/physlock-11.ebuild
new file mode 100644
index 000000000000..85ef2ee303b2
--- /dev/null
+++ b/app-misc/physlock/physlock-11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}