summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/roadnav')
-rw-r--r--app-misc/roadnav/Manifest1
-rw-r--r--app-misc/roadnav/files/roadnav-0.19-gcc45.patch26
-rw-r--r--app-misc/roadnav/metadata.xml17
-rw-r--r--app-misc/roadnav/roadnav-0.19-r1.ebuild59
4 files changed, 103 insertions, 0 deletions
diff --git a/app-misc/roadnav/Manifest b/app-misc/roadnav/Manifest
new file mode 100644
index 000000000000..ff6be1e4b450
--- /dev/null
+++ b/app-misc/roadnav/Manifest
@@ -0,0 +1 @@
+DIST roadnav-0.19.tar.gz 1289497 SHA256 6354600e10ec6be17a8f7c0282a11e80b1ad6cb4e59c979dd7e336ffcc22143e SHA512 981b7d0b506c977b5c882c7d815566450966de969f46b6ecd7deb10f418d09630e90cc12f308924d7453c3a44f7317d8e91d6b3706ecebe76a97dc62adf44b45 WHIRLPOOL cf613b7003b9800ffb89986e0dbd3496596ca7789946931a97fc749c10b03d2f44a88aa4db39e15c49559afcfda7a076a39b21817bd387aa80bd4be5b240c608
diff --git a/app-misc/roadnav/files/roadnav-0.19-gcc45.patch b/app-misc/roadnav/files/roadnav-0.19-gcc45.patch
new file mode 100644
index 000000000000..60e562bfa789
--- /dev/null
+++ b/app-misc/roadnav/files/roadnav-0.19-gcc45.patch
@@ -0,0 +1,26 @@
+diff --git a/src/GPSInterface_Serial.cpp b/src/GPSInterface_Serial.cpp
+index c3e9435..fcae209 100644
+--- a/src/GPSInterface_Serial.cpp
++++ b/src/GPSInterface_Serial.cpp
+@@ -243,7 +243,7 @@ IGPSInterface::EGPSStatus GPSInterface_Serial::GetData(wxGPSEvent * pGPSEvent)
+
+ // Echo DeLorme Tripmate's and Earthmate's hello message
+ LibRoadnavDebug1(wxT("SerialIO"), wxT("Echoing hello message: %s"), strSentence.c_str());
+- sprintf(szOut, "%s\r\n", strSentence.mb_str(*wxConvCurrent));
++ sprintf(szOut, "%s\r\n", static_cast<const char *>(strSentence.mb_str(*wxConvCurrent)));
+ WriteSerial(szOut);
+ }
+ else if (!VerifyGPSChecksum(strSentence)) // check NMEA validity
+diff --git a/src/TTS_Festival.cpp b/src/TTS_Festival.cpp
+index 8623cb3..2950490 100644
+--- a/src/TTS_Festival.cpp
++++ b/src/TTS_Festival.cpp
+@@ -88,7 +88,7 @@ ITTS::ETTSStatus TTS_Festival::Speak(const wxString & strText)
+ ppszArgs[2],
+ 64 + strText.Length(),
+ wxT("echo \\(SayText \\\"%ss\\\"\\) | festival"),
+- strText.mb_str(*wxConvCurrent)
++ static_cast<const char *>(strText.mb_str(*wxConvCurrent))
+ );
+
+ wxExecute(ppszArgs, wxEXEC_SYNC);
diff --git a/app-misc/roadnav/metadata.xml b/app-misc/roadnav/metadata.xml
new file mode 100644
index 000000000000..29dde1bff37a
--- /dev/null
+++ b/app-misc/roadnav/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andrew.cremins@gmail.com</email>
+ </maintainer>
+ <use>
+ <flag name="festival">Enable support for
+ <pkg>app-accessibility/festival</pkg></flag>
+ <flag name="openstreetmap">Enable openstreetmap support</flag>
+ <flag name="scripting">Enable scripting support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">roadnav</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/roadnav/roadnav-0.19-r1.ebuild b/app-misc/roadnav/roadnav-0.19-r1.ebuild
new file mode 100644
index 000000000000..58db4b8118b7
--- /dev/null
+++ b/app-misc/roadnav/roadnav-0.19-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=2.8
+
+inherit eutils wxwidgets
+
+DESCRIPTION="Roadnav is a street map application with routing and GPS support"
+HOMEPAGE="http://roadnav.sourceforge.net"
+SRC_URI="mirror://sourceforge/roadnav/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gps festival openstreetmap scripting" #flite, see bug #516426
+
+DEPEND="
+ x11-libs/wxGTK:2.8[X]
+ ~dev-libs/libroadnav-${PV}
+ festival? ( app-accessibility/festival )
+ gps? ( sci-geosciences/gpsd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable festival) \
+ $(use_enable gps gpsd) \
+ $(use_enable openstreetmap) \
+ $(use_enable scripting) \
+ --disable-flite \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ default
+
+ # generic or empty
+ for f in NEWS COPYING INSTALL; do
+ rm -f "${D}"/usr/share/doc/${PN}/${f}
+ done
+
+ # --docdir is broken and hardcoded to ${PN}
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${P}
+
+ domenu "${S}"/roadnav.desktop
+}
+
+pkg_postinst() {
+ echo
+ elog "After upgrading to ${P} you will need to recompile your maps."
+ echo
+}