summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild (renamed from app-mobilephone/scmxx/scmxx-0.9.0.ebuild)17
1 files changed, 13 insertions, 4 deletions
diff --git a/app-mobilephone/scmxx/scmxx-0.9.0.ebuild b/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild
index 2df2b2dcf4ea..ee5459b3efd1 100644
--- a/app-mobilephone/scmxx/scmxx-0.9.0.ebuild
+++ b/app-mobilephone/scmxx/scmxx-0.9.0-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Exchange data with Siemens phones"
HOMEPAGE="http://www.hendrik-sattler.de/scmxx/"
@@ -13,8 +15,15 @@ KEYWORDS="~amd64 x86"
IUSE="bluetooth nls"
RDEPEND="bluetooth? ( net-wireless/bluez )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
src_install() {
default