summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-4.0_p44.ebuild')
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 17211a6c3eff..48cd10c0c89c 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -84,14 +84,15 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )