summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pstotext/pstotext-1.9-r3.ebuild')
-rw-r--r--app-text/pstotext/pstotext-1.9-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/pstotext/pstotext-1.9-r3.ebuild b/app-text/pstotext/pstotext-1.9-r3.ebuild
new file mode 100644
index 000000000000..75857bb812d0
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.9-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+RDEPEND="app-text/ghostscript-gpl"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-quote-chars-fix.patch \
+ "${FILESDIR}"/${PV}-flags.patch
+ tc-export CC
+}
+
+src_install () {
+ dobin pstotext || die
+ doman pstotext.1 || die
+}