summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/ed25519/ed25519-0.0.20160420.ebuild')
-rw-r--r--dev-go/ed25519/ed25519-0.0.20160420.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/ed25519/ed25519-0.0.20160420.ebuild b/dev-go/ed25519/ed25519-0.0.20160420.ebuild
new file mode 100644
index 000000000000..8a881278c70f
--- /dev/null
+++ b/dev-go/ed25519/ed25519-0.0.20160420.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=github.com/agl/ed25519
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="278e1ec8e8a6e017cd07577924d6766039146ced"
+
+DESCRIPTION="ed25519 for Go"
+HOMEPAGE="https://github.com/agl/ed25519/"
+SRC_URI="https://github.com/agl/ed25519/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""