summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/ehcache')
-rw-r--r--dev-java/ehcache/Manifest2
-rw-r--r--dev-java/ehcache/ehcache-1.1-r1.ebuild53
-rw-r--r--dev-java/ehcache/ehcache-1.1-r2.ebuild39
-rw-r--r--dev-java/ehcache/ehcache-1.2.4-r3.ebuild42
-rw-r--r--dev-java/ehcache/ehcache-1.2.4-r4.ebuild41
-rw-r--r--dev-java/ehcache/files/build.xml-1.2.4-r219
-rw-r--r--dev-java/ehcache/metadata.xml8
7 files changed, 204 insertions, 0 deletions
diff --git a/dev-java/ehcache/Manifest b/dev-java/ehcache/Manifest
new file mode 100644
index 000000000000..7a79ab44c1dc
--- /dev/null
+++ b/dev-java/ehcache/Manifest
@@ -0,0 +1,2 @@
+DIST ehcache-1.1.tgz 228733 SHA256 b1709cdb27a7dee9c3f6beb8967a2f64549d9cc32af7867f8fa43b0d5b4bf226 SHA512 15d37d4a2579fe1b720b87954a135307af34c42c6a925b13cca0f8d861e92c3802696480e3a8c3e478e905f0a231b0d93c135ff75fb934e7a968ba790713d9d5 WHIRLPOOL c32e92bae557e20cab01421104da3cba7f02654c8f262403fcd1f93598afb62570a14aadc3989a07a6de68ba8a34ad8dc04402b3a6a4f62f6fddc291e7aed34a
+DIST ehcache-1.2.4.tgz 1330344 SHA256 47b5dad87d8c75773e66aef471b1b464118956f8ce3bf9ca0e0292f020a20a64 SHA512 a8d3e7c47eeeab568fbe2f4b923db96cf0f93d8ae0f727aa107b0ce5c5abd035a3967ea58617ff10e9c81109dcb8d904cbad86ec2c77d9be159e1a0a2c44d4ed WHIRLPOOL ed7913a200c45119f565912118b1b7c9e9e6ffc29fe8e227c7eca3d66f2333636d214af6e39ba9cf41c6eb0cf4568e26e1b511c06b66b3abdde8a6cba814178e
diff --git a/dev-java/ehcache/ehcache-1.1-r1.ebuild b/dev-java/ehcache/ehcache-1.1-r1.ebuild
new file mode 100644
index 000000000000..bd6ead79108b
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+COMMON_DEPEND="
+ dev-java/commons-collections
+ dev-java/concurrent-util
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ >=dev-java/ant-core-1.5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip ${P}-src.zip || die
+ rm *.jar
+ rm -rf src/net/sf/ehcache/hibernate
+}
+
+src_compile() {
+ mkdir "${S}"/classes
+ cd "${S}"/src
+
+ ejavac -d "${S}"/classes \
+ -classpath $(java-pkg_getjars commons-logging,commons-collections) \
+ $(find . -name "*.java")
+
+ cd "${S}"/classes
+ jar cf "${S}"/${P}.jar * || die
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/${P}.jar ${PN}.jar
+ dodoc *.txt ehcache.xml ehcache.xsd
+ if use doc ; then
+ unzip ${P}-javadoc.zip || die
+ java-pkg_dohtml -r docs
+ fi
+}
diff --git a/dev-java/ehcache/ehcache-1.1-r2.ebuild b/dev-java/ehcache/ehcache-1.1-r2.ebuild
new file mode 100644
index 000000000000..2737962129e4
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/commons-collections:0
+ dev-java/concurrent-util:0
+ dev-java/commons-logging:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/zip
+ ${COMMON_DEPEND}
+ >=dev-java/ant-core-1.5"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="commons-collections,concurrent-util,commons-logging"
+
+java_prepare() {
+ unzip ${P}-src.zip || die
+ rm *.jar || die
+ rm -rf src/net/sf/ehcache/hibernate || die
+}
diff --git a/dev-java/ehcache/ehcache-1.2.4-r3.ebuild b/dev-java/ehcache/ehcache-1.2.4-r3.ebuild
new file mode 100644
index 000000000000..2a2cfde97c6d
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.2.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="1.2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ java-virtuals/servlet-api:2.4"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="commons-collections,commons-logging,servlet-api-2.4"
+
+java_prepare() {
+ unzip -d src ${P}-sources.jar || die
+ rm -rf src/net/sf/ehcache/hibernate || die
+ rm *.jar || die
+}
diff --git a/dev-java/ehcache/ehcache-1.2.4-r4.ebuild b/dev-java/ehcache/ehcache-1.2.4-r4.ebuild
new file mode 100644
index 000000000000..d6477b931e02
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.2.4-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+CDEPEND="dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ java-virtuals/servlet-api:2.5"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_PKG_WANT_SOURCE="1.7"
+JAVA_PKG_WANT_TARGET="1.7"
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="commons-collections,commons-logging,servlet-api-2.5"
+
+java_prepare() {
+ unzip -d src ${P}-sources.jar || die
+ rm -rf src/net/sf/ehcache/hibernate || die
+ rm *.jar || die
+}
diff --git a/dev-java/ehcache/files/build.xml-1.2.4-r2 b/dev-java/ehcache/files/build.xml-1.2.4-r2
new file mode 100644
index 000000000000..468cd44b52aa
--- /dev/null
+++ b/dev-java/ehcache/files/build.xml-1.2.4-r2
@@ -0,0 +1,19 @@
+<?xml version="1.0"?>
+<project name="ehcache" default="jar" basedir=".">
+ <path id="globalClassPath">
+ <fileset dir="lib/" includes="*.jar"/>
+ </path>
+ <target name="compile">
+ <mkdir dir="classes"/>
+ <javac srcdir="src" destdir="classes/" classpathref="globalClassPath"/>
+ <copy todir="classes/">
+ <fileset dir="." includes="ehcache-failsafe.xml"/>
+ </copy>
+ </target>
+ <target name="jar" depends="compile">
+ <jar destfile="ehcache.jar">
+ <fileset dir="classes" includes="**/*.class"/>
+ <fileset dir="classes" includes="**/*.xml"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/ehcache/metadata.xml b/dev-java/ehcache/metadata.xml
new file mode 100644
index 000000000000..fbc3b22c98e8
--- /dev/null
+++ b/dev-java/ehcache/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">ehcache</remote-id>
+ </upstream>
+</pkgmetadata>