summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnucobol/gnucobol-3.1.2.ebuild')
-rw-r--r--dev-lang/gnucobol/gnucobol-3.1.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
deleted file mode 100644
index 1222244af391..000000000000
--- a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="A free/libre COBOL compiler"
-HOMEPAGE="https://gnucobol.sourceforge.io/"
-SRC_URI="https://downloads.sourceforge.net/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
-
-LICENSE="GPL-3 LGPL-3 FDL-1.3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="berkdb json nls xml"
-
-RDEPEND="
- dev-libs/gmp:=
- sys-libs/ncurses:=
- json? ( dev-libs/json-c:= )
- xml? ( dev-libs/libxml2 )
- berkdb? ( sys-libs/db:4.8= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-build/libtool"
-
-DOCS=( AUTHORS ChangeLog NEWS README README.md )
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-ncurses.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with berkdb db) \
- $(use_with json) \
- $(use_with xml xml2) \
- $(use_enable nls)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}