summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pocl/pocl-0.11.ebuild')
-rw-r--r--dev-lang/pocl/pocl-0.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/pocl/pocl-0.11.ebuild b/dev-lang/pocl/pocl-0.11.ebuild
new file mode 100644
index 000000000000..f55e02299d13
--- /dev/null
+++ b/dev-lang/pocl/pocl-0.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PortableCL: opensource implementation of the OpenCL standard"
+HOMEPAGE="http://portablecl.org/"
+SRC_URI="http://portablecl.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/ocl-icd
+ =sys-devel/llvm-3.6*
+ sys-apps/hwloc"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ # Needs an OpenCL 1.2 ICD, mesa and nvidia are invalid
+ # Maybe ati works, feel free to add/fix if you can test
+ if [[ $(eselect opencl show) == 'ocl-icd' ]]; then
+ einfo "Valid OpenCL ICD set"
+ else
+ eerror "Please use a supported ICD:"
+ eerror "eselect opencl set ocl-icd"
+ die "OpenCL ICD not set to a supported value"
+ fi
+}