summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index e5aab379b782..cc8708c2e131 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1 +1,2 @@
DIST aiohappyeyeballs-2.4.4.gh.tar.gz 61087 BLAKE2B 7e7eeaa8f8f589e5d081dc0218ee8aff0cc7fb81cdb59d42355fb42f2586c3c1abe82ce4bb5afe40f06a5978dc1b07d3257c9cfabd2013e4f8ff63ff768326e0 SHA512 b822aab388d5b32aae58a2f5b7f8e9d0574962487e64ed0d7040767daf8684680272ba43b2c8d7feaf78649465510eb003b3e10c45d4417832123d7ee10ea5d0
+DIST aiohappyeyeballs-2.4.6.gh.tar.gz 72830 BLAKE2B aea6f5e20a2900fb5d498722edc5e1b776552ff4ca84120f2e1acea5478a571ab923d3bca4c58111f5ff0389ddb7f4976f6231b575b7b282e3c45e4adebb9707 SHA512 0098f13604c929998981deaa9ae221f0c5c4c4de46e5063b23e185e1437637b35256ebc91a3f7fdf6b5f9dee6f4be5ff3c215a8ddd34a02a0389c9b49c329c16
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.6.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.6.ebuild
new file mode 100644
index 000000000000..47f81490d8cc
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}