summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/orderly-set/orderly-set-5.3.0.ebuild')
-rw-r--r--dev-python/orderly-set/orderly-set-5.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/orderly-set/orderly-set-5.3.0.ebuild b/dev-python/orderly-set/orderly-set-5.3.0.ebuild
new file mode 100644
index 000000000000..e9796b5e8bab
--- /dev/null
+++ b/dev-python/orderly-set/orderly-set-5.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A package containing multiple implementations of Ordered Set"
+HOMEPAGE="
+ https://github.com/seperman/orderly-set/
+ https://pypi.org/project/orderly-set/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditional mypy dep for a test that is not even run
+ # https://github.com/seperman/orderly-set/pull/5
+ sed -i -e '/mypy\.api/d' tests/*.py || die
+}